PHP 5.4.x < 5.4.29 の「src/cdf.c」の複数の脆弱性

medium Nessus プラグイン ID 74291
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモート Web サーバーは、複数の脆弱性の影響を受ける PHP バージョンを使用しています。

説明

バナーによると、リモートホストにインストールされている PHP 5.4.x のバージョンは、5.4.29 より前です。したがって、次の脆弱性の影響を受けます:

- 「src/cdf.c」内の「cdf_unpack_summary_info()」関数に欠陥が存在し、特別に作り上げられた CDF ファイルを処理するときに、複数の file_printf 呼び出しが発生します。
これにより、コンテキストに依存する攻撃者が、PHP を使って Web アプリケーションをクラッシュできることがあります。(CVE-2014-0237)

- 「src/cdf.c」内の「cdf_read_property_info()」関数に欠陥が存在し、特別に細工された CDF ファイルを処理するときに、無限ループが発生します。これにより、コンテキストに依存する攻撃者が、PHP を使って Web アプリケーションをクラッシュできることがあります。(CVE-2014-0238)
- printf に領域外読み取りが存在します。(バグ #67249)

注意:Nessus はこれらの問題の悪用を試みていませんが、その代わりにアプリケーションの自己報告されたバージョン番号のみに依存しています。

ソリューション

PHP バージョン 5.4.29 または以降にアップグレードしてください。

関連情報

http://www.php.net/ChangeLog-5.php#5.4.29

https://bugs.php.net/bug.php?id=67327

https://bugs.php.net/bug.php?id=67328

プラグインの詳細

深刻度: Medium

ID: 74291

ファイル名: php_5_4_29.nasl

バージョン: 1.5

タイプ: remote

ファミリー: CGI abuses

公開日: 2014/6/3

更新日: 2021/1/19

依存関係: php_version.nasl

リスク情報

VPR

リスクファクター: Low

スコア: 3.6

CVSS v2

リスクファクター: Medium

Base Score: 5

Temporal Score: 3.7

ベクトル: AV:N/AC:L/Au:N/C:N/I:N/A:P

現状ベクトル: E:U/RL:OF/RC:C

脆弱性情報

CPE: cpe:/a:php:php

必要な KB アイテム: www/PHP

エクスプロイトの容易さ: No exploit is required

パッチ公開日: 2014/5/29

脆弱性公開日: 2014/5/22

参照情報

CVE: CVE-2014-0237, CVE-2014-0238

BID: 67759, 67765, 69271