openSUSE のセキュリティ更新:postgresql / postgresql-libs(openSUSE-SU-2012:1251-1)

medium Nessus プラグイン ID 74766
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモート openSUSE ホストに、セキュリティ更新がありません。

説明

- セキュリティおよびバグ修正リリース 9.1.5:

- 手順言語の呼び出しハンドラー用の SECURITY DEFINER および SET の属性を無視してください(CVE-2012-2655)bnc#765069

- 「contrib/pgcrypto」の DES crypt() 関数の不適切なパスワード転送を修正します(CVE-2012-2143)bnc#766799

- 「contrib/xml2」の xslt_process() 経由の外部ファイル/URL へのアクセスを防止します(CVE-2012-3488)bnc#776523

- XML エンティティ参照経由の外部ファイル/URL へのアクセスを防止します(CVE-2012-3489))bnc#776524

残りの変更についてはリリースノートを参照してください:
http://www.postgresql.org/docs/9.1/static/release.html/usr/share/doc/packages/postgresql/HISTORY

ソリューション

影響を受ける postgresql / postgresql-libs パッケージを更新してください。

関連情報

https://www.postgresql.org/docs/9.1/release.html

https://bugzilla.novell.com/show_bug.cgi?id=765069

https://bugzilla.novell.com/show_bug.cgi?id=766797

https://bugzilla.novell.com/show_bug.cgi?id=776523

https://bugzilla.novell.com/show_bug.cgi?id=776524

https://lists.opensuse.org/opensuse-updates/2012-09/msg00102.html

プラグインの詳細

深刻度: Medium

ID: 74766

ファイル名: openSUSE-2012-650.nasl

バージョン: 1.7

タイプ: local

エージェント: unix

公開日: 2014/6/13

更新日: 2021/1/19

依存関係: ssh_get_info.nasl

リスク情報

VPR

リスクファクター: Medium

スコア: 4

CVSS v2

リスクファクター: Medium

Base Score: 4.9

Temporal Score: 3.6

ベクトル: AV:N/AC:M/Au:S/C:P/I:P/A:N

現状ベクトル: E:U/RL:OF/RC:C

脆弱性情報

CPE: p-cpe:/a:novell:opensuse:libecpg6, p-cpe:/a:novell:opensuse:libecpg6-debuginfo, p-cpe:/a:novell:opensuse:libpq5, p-cpe:/a:novell:opensuse:libpq5-32bit, p-cpe:/a:novell:opensuse:libpq5-debuginfo, p-cpe:/a:novell:opensuse:libpq5-debuginfo-32bit, p-cpe:/a:novell:opensuse:postgresql, p-cpe:/a:novell:opensuse:postgresql-contrib, p-cpe:/a:novell:opensuse:postgresql-contrib-debuginfo, p-cpe:/a:novell:opensuse:postgresql-debuginfo, p-cpe:/a:novell:opensuse:postgresql-debugsource, p-cpe:/a:novell:opensuse:postgresql-devel, p-cpe:/a:novell:opensuse:postgresql-devel-32bit, p-cpe:/a:novell:opensuse:postgresql-devel-debuginfo, p-cpe:/a:novell:opensuse:postgresql-devel-debuginfo-32bit, p-cpe:/a:novell:opensuse:postgresql-libs-debugsource, p-cpe:/a:novell:opensuse:postgresql-plperl, p-cpe:/a:novell:opensuse:postgresql-plperl-debuginfo, p-cpe:/a:novell:opensuse:postgresql-plpython, p-cpe:/a:novell:opensuse:postgresql-plpython-debuginfo, p-cpe:/a:novell:opensuse:postgresql-pltcl, p-cpe:/a:novell:opensuse:postgresql-pltcl-debuginfo, p-cpe:/a:novell:opensuse:postgresql-server, p-cpe:/a:novell:opensuse:postgresql-server-debuginfo, cpe:/o:novell:opensuse:12.1

必要な KB アイテム: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2012/9/18

参照情報

CVE: CVE-2012-2143, CVE-2012-2655, CVE-2012-3488, CVE-2012-3489