openSUSE セキュリティ更新:libvorbis(openSUSE-SU-2012:0319-1)

critical Nessus プラグイン ID 75933

概要

リモート openSUSE ホストに、セキュリティ更新がありません。

説明

特別に細工された ogg ファイルにより、 Vorbis オーディオ圧縮ライブラリでヒープベースのバッファオーバーフローが発生する可能性があります。攻撃者がこれを悪用して、クラッシュを引き起こしたり、任意のコードを実行したりする可能性があります(CVE-2012-0444)。

ソリューション

影響を受ける libvorbis パッケージを更新してください。

関連情報

https://bugzilla.novell.com/show_bug.cgi?id=747912

https://lists.opensuse.org/opensuse-updates/2012-03/msg00000.html

プラグインの詳細

深刻度: Critical

ID: 75933

ファイル名: suse_11_4_libvorbis-120221.nasl

バージョン: 1.4

タイプ: local

エージェント: unix

公開日: 2014/6/13

更新日: 2021/1/19

サポートされているセンサー: Nessus Agent

リスク情報

VPR

リスクファクター: Medium

スコア: 5.9

CVSS v2

リスクファクター: Critical

Base Score: 10

ベクトル: AV:N/AC:L/Au:N/C:C/I:C/A:C

脆弱性情報

CPE: p-cpe:/a:novell:opensuse:libvorbis-debugsource, p-cpe:/a:novell:opensuse:libvorbis-devel, p-cpe:/a:novell:opensuse:libvorbis0, p-cpe:/a:novell:opensuse:libvorbis0-32bit, p-cpe:/a:novell:opensuse:libvorbis0-debuginfo, p-cpe:/a:novell:opensuse:libvorbis0-debuginfo-32bit, p-cpe:/a:novell:opensuse:libvorbisenc2, p-cpe:/a:novell:opensuse:libvorbisenc2-32bit, p-cpe:/a:novell:opensuse:libvorbisenc2-debuginfo, p-cpe:/a:novell:opensuse:libvorbisenc2-debuginfo-32bit, p-cpe:/a:novell:opensuse:libvorbisfile3, p-cpe:/a:novell:opensuse:libvorbisfile3-32bit, p-cpe:/a:novell:opensuse:libvorbisfile3-debuginfo, p-cpe:/a:novell:opensuse:libvorbisfile3-debuginfo-32bit, cpe:/o:novell:opensuse:11.4

必要な KB アイテム: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

パッチ公開日: 2012/2/21

参照情報

CVE: CVE-2012-0444