PHP 5.4.x < 5.4.30 の複数の脆弱性

high Nessus プラグイン ID 76281

概要

リモート Web サーバーが実行しているバージョンの PHP は、複数の脆弱性の影響を受けます。

説明

バナーによると、リモートホストにインストールされている PHP 5.4.x のバージョンは、5.4.30 より前です。したがって、次の脆弱性の影響を受けます:

- Fileinfo 拡張、Composite Document Format(CDF)の処理、「cdf_read_short_sector」、「cdf_check_stream_offset」、「cdf_count_chain」および「cdf_read_property_info」の関数に関連して境界検査エラーが存在します。(CVE-2014-0207、CVE-2014-3479、CVE-2014-3480、 CVE-2014-3487)

- Fileinfo 拡張と関数「mconvert」に関連する Pascal 文字列のサイズ処理のエラーが存在します。
(CVE-2014-3478)

- Standard PHP Library(SPL)拡張と関数「unserialize」に関連する型の取り違え(Type Confusion)エラーが存在します。(CVE-2014-3515)

- 構成スクリプトと一時ファイルの処理に関連して、エラーが存在し、安全でないファイルを使用する可能性があります。(CVE-2014-3981)

- 関数「dns_get_record」に関連するヒープベースのバッファオーバーフローエラーが存在するため、任意のコード実行が発生する可能性があります。(CVE-2014-4049)

- 関数「php_print_info」に関連して、型の取り違え(Type Confusion)エラーが存在し、これにより機密情報が漏洩する可能性があります。(CVE-2014-4721)

- 文字列の終端を適切にチェックしないために、timelib_meridian_with_check() 関数に領域外読み取りのエラーが存在します。リモートの攻撃者がこれを悪用して、サービス拒否状態を起こしたり、メモリコンテンツを漏洩させたりする可能性があります。(OSVDB 130082)

- 日付解析ルーチンが文字列の終端を適切にチェックしないために、date_parse_from_format() 関数に領域外読み取りのエラーが存在します。リモートの攻撃者がこれを悪用して、サービス拒否状態を起こしたり、メモリコンテンツを漏洩させたりする可能性があります。(OSVDB 130083)

- 非シリアル化および「SplFileObject」処理に関連するエラーがあることにより、サービス拒否攻撃が実行される可能性があります。(バグ #67072)

- Intl 拡張とメソッド「Locale::parseLocale」に関連して二重解放のエラーが存在し、特定されない影響が及ぶ可能性があります。(バグ #67349)

- Intl 拡張と関数「locale_get_display_name」と「uloc_getDisplayName」に関連してバッファオーバーフローのエラーが存在し、特定されない影響が及ぶ可能性があります。
(バグ #67397)

注意:Nessus はこれらの問題の悪用を試みていませんが、その代わりにアプリケーションの自己報告されたバージョン番号のみに依存しています。

ソリューション

PHP バージョン 5.4.30 または以降にアップグレードしてください。

関連情報

http://www.php.net/ChangeLog-5.php#5.4.30

https://bugs.php.net/bug.php?id=67072

https://bugs.php.net/bug.php?id=67326

https://bugs.php.net/bug.php?id=67349

https://bugs.php.net/bug.php?id=67390

https://bugs.php.net/bug.php?id=67397

https://bugs.php.net/bug.php?id=67410

https://bugs.php.net/bug.php?id=67411

https://bugs.php.net/bug.php?id=67412

https://bugs.php.net/bug.php?id=67413

https://bugs.php.net/bug.php?id=67432

https://bugs.php.net/bug.php?id=67492

https://bugs.php.net/bug.php?id=67498

https://bugs.php.net/bug.php?id=67253

https://bugs.php.net/bug.php?id=67251

https://seclists.org/oss-sec/2014/q3/29

https://www.sektioneins.de/en/blog/14-07-04-phpinfo-infoleak.html

プラグインの詳細

深刻度: High

ID: 76281

ファイル名: php_5_4_30.nasl

バージョン: 1.20

タイプ: remote

ファミリー: CGI abuses

公開日: 2014/6/27

更新日: 2022/4/11

リスク情報

CVSS スコアのソース: CVE-2014-3515

VPR

リスクファクター: Medium

スコア: 5.9

CVSS v2

リスクファクター: High

Base Score: 7.5

Temporal Score: 5.5

ベクトル: AV:N/AC:L/Au:N/C:P/I:P/A:P

現状ベクトル: E:U/RL:OF/RC:C

脆弱性情報

CPE: cpe:/a:php:php

必要な KB アイテム: www/PHP

エクスプロイトの容易さ: No exploit is required

パッチ公開日: 2014/6/26

脆弱性公開日: 2014/6/26

参照情報

CVE: CVE-2014-0207, CVE-2014-3478, CVE-2014-3479, CVE-2014-3480, CVE-2014-3487, CVE-2014-3515, CVE-2014-3981, CVE-2014-4049, CVE-2014-4721

BID: 67837, 68007, 68120, 68237, 68238, 68239, 68241, 68243, 68423, 68550