Oracle Linux 7:gnutls(ELSA-2014-0684)

medium Nessus プラグイン ID 76731
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモート Oracle Linux ホストに、1 つ以上のセキュリティ更新がありません。

説明

Red Hat セキュリティアドバイザリ 2014:0684 から:

2 つのセキュリティ上の問題を修正する更新済みの gnutls パッケージが、Red Hat Enterprise Linux 7 で現在利用可能です。

Red Hat セキュリティレスポンスチームは、この更新には重大なセキュリティ上の影響があると評価しています。詳細な重要度の評価を提供する Common Vulnerability Scoring System (CVSS)のベーススコアが、「参照」セクションの CVE リンクの各脆弱性に対して利用可能です。

GnuTLS ライブラリは、暗号アルゴリズムおよび Transport Layer Security(TLS)のようなプロトコルのサポートを提供します。

TLS/SSL ハンドシェイクの ServerHello メッセージから GnuTLS がセッション ID を解析する方法で、欠陥が見つかりました。悪意あるサーバーが、この欠陥を利用して、 GnuTLS を使って TLS/SSL クライアントアプリケーションを接続する際にバッファオーバーフローを引き起こす過度に長いセッション ID 値を送信することが可能です。これにより、クライアントアプリケーションがクラッシュしたり、任意のコードが実行されたりする可能性があります。(CVE-2014-3466)

GnuTLS が X.509 証明書を解析していた方法で、NULL ポインターデリファレンスの欠陥が見つかりました。特別に細工された証明書により、GnuTLS を使用しているサーバーやクライアントアプリケーションをクラッシュさせることができます。(CVE-2014-3465)

Red Hat は、これらの問題を報告してくれた GnuTLS の Upstream に感謝の意を表します。Upstream は Codenomicon の Joonas Kuorilehto 氏を CVE-2014-3466 の最初の報告者として認めます。

GnuTLS のユーザーは、これらの更新済みパッケージへアップグレードし、これらの問題を修正することが推奨されます。更新した内容を反映させるには、GnuTLS ライブラリにリンクされているすべてのアプリケーションを再起動する必要があります。

ソリューション

影響を受ける GnuTLS パッケージを更新してください。

関連情報

https://oss.oracle.com/pipermail/el-errata/2014-July/004274.html

プラグインの詳細

深刻度: Medium

ID: 76731

ファイル名: oraclelinux_ELSA-2014-0684.nasl

バージョン: 1.7

タイプ: local

エージェント: unix

公開日: 2014/7/24

更新日: 2021/1/14

依存関係: ssh_get_info.nasl

リスク情報

VPR

リスクファクター: Medium

スコア: 5.9

CVSS v2

リスクファクター: Medium

Base Score: 6.8

Temporal Score: 5.9

ベクトル: AV:N/AC:M/Au:N/C:P/I:P/A:P

現状ベクトル: E:ND/RL:OF/RC:C

脆弱性情報

CPE: p-cpe:/a:oracle:linux:gnutls, p-cpe:/a:oracle:linux:gnutls-c%2b%2b, p-cpe:/a:oracle:linux:gnutls-dane, p-cpe:/a:oracle:linux:gnutls-devel, p-cpe:/a:oracle:linux:gnutls-utils, cpe:/o:oracle:linux:7

必要な KB アイテム: Host/local_checks_enabled, Host/OracleLinux, Host/RedHat/release, Host/RedHat/rpm-list

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2014/7/23

脆弱性公開日: 2014/6/3

参照情報

CVE: CVE-2014-3465, CVE-2014-3466

BID: 67739, 67741

RHSA: 2014:0684