WordPress < 3.7.4 / 3.8.4 / 3.9.2 複数の脆弱性

high Nessus プラグイン ID 77157
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモート Web サーバーには、複数の脆弱性に影響を受ける PHP アプリケーションが含まれています。

説明

そのバージョン番号によると、リモートWeb サーバーにホストされている WordPress アプリケーションは、複数の脆弱性の影響を受けます:

- 「getid3.lib.php」に、パーサーが信頼できないソースからの XML 外部エンティティを受け入れることによる、XML インジェクションの欠陥が存在します。特別に細工された XML データを使用して、リモートの攻撃者が、機密情報にアクセスしたり、サービス拒否を引き起こしたりする可能性があります。これは、3.7.4 と 3.8.4 を除く 3.6 ~ 3.9.1 のバージョンに影響を与えます。

- パーサーが XML 内部エンティティを適切に検証せずに受け入れることによる、XML インジェクションの欠陥が「xmlrpc.php」に存在します。特別に細工された XML を使用して、リモートの攻撃者が、サービス拒否を引き起こす可能性があります。
これは、3.7.4 と 3.8.4 を除く 1.5 ~ 3.9.1 のバージョンに影響を与えます。

- ウィジットを処理する際に、スクリプト「/src/wp-includes/class-wp-customize-widgets.php」に安全でないシリアル化の欠陥が存在しています。これにより、リモートの攻撃者は、任意のコードを実行する可能性があります。バージョン 3.9 および 3.9.1 非デフォルト構成が影響を受けています。

- デリミタで個々に分離しておらず、時定数で nonce を比較していないため、CSRF トークンの構築を行う際に欠陥が存在しています。これにより、リモートの攻撃者がブルートフォース攻撃を仕掛けることや、CSRF トークンを漏洩する可能性があります。これは、3.7.4 と 3.8.4 を除く 2.0.3 ~ 3.9.1 のバージョンに影響を与えます。

- アバターからの入力がユーザー戻される前に検証されない、「/src/wp-includes/pluggable.php」内のスクリプトの「get_avatar」関数に、クロスサイトスクリプティングの欠陥が存在しています。特別に細工されたリクエストを使用して、認証された攻撃者が、ブラウザ/サーバー信頼関係内で任意のスクリプトコードを実行する可能性があります。これは、バージョン 3.9.1 に影響を与えます。

Nessus はこれらの問題に対してテストされていませんが、その代わりにアプリケーションの自己報告されたバージョン番号のみに依存していることに、注意してください。

ソリューション

WordPress 3.7.4 / 3.8.4 / 3.9.2 またはそれ以降にアップグレードしてください。

関連情報

https://wordpress.org/news/2014/08/wordpress-3-9-2/

https://codex.wordpress.org/Version_3.9.2

https://seclists.org/oss-sec/2014/q3/301

https://core.trac.wordpress.org/changeset/29405/branches/3.9

https://core.trac.wordpress.org/changeset/29389

https://core.trac.wordpress.org/changeset/29390

https://core.trac.wordpress.org/changeset/29384

https://core.trac.wordpress.org/changeset/29408

https://core.trac.wordpress.org/changeset/29398

プラグインの詳細

深刻度: High

ID: 77157

ファイル名: wordpress_3_9_2.nasl

バージョン: 1.15

タイプ: remote

ファミリー: CGI abuses

公開日: 2014/8/12

更新日: 2021/1/19

依存関係: wordpress_detect.nasl

構成: パラノイドモードの有効化

リスク情報

VPR

リスクファクター: Medium

スコア: 5.9

CVSS v2

リスクファクター: High

Base Score: 7.5

Temporal Score: 5.5

ベクトル: AV:N/AC:L/Au:N/C:P/I:P/A:P

現状ベクトル: E:U/RL:OF/RC:C

脆弱性情報

CPE: cpe:/a:wordpress:wordpress

必要な KB アイテム: www/PHP, installed_sw/WordPress, Settings/ParanoidReport

エクスプロイトの容易さ: No exploit is required

パッチ公開日: 2014/8/6

脆弱性公開日: 2014/3/7

参照情報

CVE: CVE-2014-2053, CVE-2014-5203, CVE-2014-5204, CVE-2014-5205, CVE-2014-5240, CVE-2014-5265, CVE-2014-5266

BID: 69096

CWE: 20, 74, 79, 442, 629, 711, 712, 722, 725, 750, 751, 800, 801, 809, 811, 864, 900, 928, 931, 990