PHP 5.3.x < 5.3.29 の複数の脆弱性

high Nessus プラグイン ID 77285
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモート Web サーバーは、複数の脆弱性の影響を受ける PHP バージョンを使用しています。

説明

バナーによると、リモートホストにインストールされている PHP のバージョンは、5.3.x の 5.3.29 より前です。したがって、次の脆弱性の影響を受けます:

- ファイル「ext/date/lib/parse_iso_intervals.c」に、DateInterval オブジェクトの処理に関連するヒープベースのバッファオーバーフローエラーが存在します。このため、DoS 攻撃(サービス拒否攻撃)を引き起こす可能性があります。(CVE-2013-6712)

- Fileinfo 拡張、Composite Document Format(CDF)の処理、および「cdf_read_short_sector」関数に関連する境界検査エラーが存在します。(CVE-2014-0207)

- 「src/cdf.c」内の「cdf_unpack_summary_info()」関数に欠陥が存在し、特別に作り上げられた CDF ファイルを処理するときに、複数の file_printf 呼び出しが発生します。
これにより、コンテキストに依存する攻撃者が、PHP を使って Web アプリケーションをクラッシュできることがあります。(CVE-2014-0237)

- 「src/cdf.c」内の「cdf_read_property_info()」関数に欠陥が存在し、特別に細工された CDF ファイルを処理するときに、無限ループが発生します。これにより、コンテキストに依存する攻撃者が、PHP を使って Web アプリケーションをクラッシュできることがあります。(CVE-2014-0238)

- Standard PHP Library(SPL)拡張と関数「unserialize」に関連する型の取り違え(Type Confusion)エラーが存在します。(CVE-2014-3515)

- 構成スクリプトと一時ファイルの処理に関連して、エラーが存在し、安全でないファイルを使用する可能性があります。(CVE-2014-3981)

- 関数「dns_get_record」に関連するヒープベースのバッファオーバーフローエラーが存在するため、任意のコード実行が発生する可能性があります。(CVE-2014-4049)

- printf に領域外読み取りが存在します。(バグ #67249)

注意:Nessus はこれらの問題の悪用を試みていませんが、その代わりにアプリケーションの自己報告されたバージョン番号のみに依存しています。

注意:また、バージョン 5.3.29 のリリースは PHP 5.3.x ブランチのサポートの終了を意味します。

ソリューション

PHP バージョン 5.3.29 または以降にアップグレードしてください。

関連情報

http://php.net/archive/2014.php#id2014-08-14-1

http://www.php.net/ChangeLog-5.php#5.3.29

プラグインの詳細

深刻度: High

ID: 77285

ファイル名: php_5_3_29.nasl

バージョン: 1.10

タイプ: remote

ファミリー: CGI abuses

公開日: 2014/8/20

更新日: 2021/1/19

依存関係: php_version.nasl

リスク情報

CVSS スコアのソース: CVE-2014-3515

VPR

リスクファクター: Medium

スコア: 5.9

CVSS v2

リスクファクター: High

Base Score: 7.5

Temporal Score: 5.5

ベクトル: AV:N/AC:L/Au:N/C:P/I:P/A:P

現状ベクトル: E:U/RL:OF/RC:C

CVSS v3

リスクファクター: High

Base Score: 7.3

Temporal Score: 6.4

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: cpe:/a:php:php

必要な KB アイテム: www/PHP

エクスプロイトの容易さ: No exploit is required

パッチ公開日: 2014/8/14

脆弱性公開日: 2013/11/27

参照情報

CVE: CVE-2013-6712, CVE-2014-0207, CVE-2014-0237, CVE-2014-0238, CVE-2014-3478, CVE-2014-3479, CVE-2014-3480, CVE-2014-3487, CVE-2014-3515, CVE-2014-3981, CVE-2014-4049, CVE-2014-4721

BID: 64018, 67759, 67765, 67837, 68007, 68120, 68237, 68238, 68239, 68241, 68243, 68423, 69271, 73385