Amazon Linux AMI:gnutls(ALAS-2014-352)

medium Nessus プラグイン ID 78295
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモート Amazon Linux AMI ホストに、セキュリティ更新がありません。

説明

TLS/SSL ハンドシェイクの ServerHello メッセージから GnuTLS がセッション ID を解析する方法で、欠陥が見つかりました。悪意あるサーバーが、この欠陥を利用して、 GnuTLS を使って TLS/SSL クライアントアプリケーションを接続する際にバッファオーバーフローを引き起こす過度に長いセッション ID 値を送信することが可能です。これにより、クライアントアプリケーションがクラッシュしたり、任意のコードが実行されたりする可能性があります。(CVE-2014-3466)

ソリューション

「yum update gnutls」を実行してシステムを更新してください。

関連情報

https://alas.aws.amazon.com/ALAS-2014-352.html

プラグインの詳細

深刻度: Medium

ID: 78295

ファイル名: ala_ALAS-2014-352.nasl

バージョン: 1.3

タイプ: local

エージェント: unix

公開日: 2014/10/12

更新日: 2018/4/18

依存関係: ssh_get_info.nasl

リスク情報

VPR

リスクファクター: Medium

スコア: 5.9

CVSS v2

リスクファクター: Medium

Base Score: 6.8

ベクトル: AV:N/AC:M/Au:N/C:P/I:P/A:P

脆弱性情報

CPE: p-cpe:/a:amazon:linux:gnutls, p-cpe:/a:amazon:linux:gnutls-debuginfo, p-cpe:/a:amazon:linux:gnutls-devel, p-cpe:/a:amazon:linux:gnutls-guile, p-cpe:/a:amazon:linux:gnutls-utils, cpe:/o:amazon:linux

必要な KB アイテム: Host/local_checks_enabled, Host/AmazonLinux/release, Host/AmazonLinux/rpm-list

パッチ公開日: 2014/6/5

参照情報

CVE: CVE-2014-3466

ALAS: 2014-352

RHSA: 2014:0595