PHP 5.6.x < 5.6.2 の複数の脆弱性

high Nessus プラグイン ID 78547
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモート Web サーバーは、複数の脆弱性の影響を受ける PHP バージョンを使用しています。

説明

バナーによると、リモートホストにインストールされている PHP 5.6.x のバージョンは、5.6.2 より前です。したがって、次の脆弱性の影響を受けます:

-関数「mkgmtime」にバッファオーバーフローのエラーがあり、これにより、アプリケーションのクラッシュまたは任意のコードの実行が引き起こされる可能性があります。(CVE-2014-3668)

- 関数「unserialize」に整数オーバーフローのエラーがあり、これにより、DoS 攻撃(サービス拒否攻撃)が引き起こされる可能性があります。
注:これは 32 ビットのインスタンスにしか影響を与えません。
(CVE-2014-3669)

- 関数「exif_thumbnail」にヒープ破損のエラーがあり、これにより、アプリケーションのクラッシュまたは任意のコードの実行が引き起こされる可能性があります。(CVE-2014-3670)

- cURL 拡張のファイル「ext/curl/interface.c」および NULL オプション処理に入力検証エラーがあり、これにより、情報漏洩が引き起こされる可能性があります。(バグ #68089)

Nessus はこれらの問題の悪用を試みていませんが、その代わりにアプリケーションの自己報告されたバージョン番号のみに依存していることに、注意してください。

ソリューション

PHP バージョン 5.6.2 または以降にアップグレードしてください。

関連情報

http://www.php.net/ChangeLog-5.php#5.6.2

プラグインの詳細

深刻度: High

ID: 78547

ファイル名: php_5_6_2.nasl

バージョン: 1.9

タイプ: remote

ファミリー: CGI abuses

公開日: 2014/10/17

更新日: 2021/1/19

依存関係: php_version.nasl

リスク情報

CVSS スコアのソース: CVE-2014-3669

VPR

リスクファクター: Medium

スコア: 5.9

CVSS v2

リスクファクター: High

Base Score: 7.5

Temporal Score: 5.5

ベクトル: AV:N/AC:L/Au:N/C:P/I:P/A:P

現状ベクトル: E:U/RL:OF/RC:C

脆弱性情報

CPE: cpe:/a:php:php

必要な KB アイテム: www/PHP

エクスプロイトの容易さ: No exploit is required

パッチ公開日: 2014/10/16

脆弱性公開日: 2014/10/16

参照情報

CVE: CVE-2014-3668, CVE-2014-3669, CVE-2014-3670

BID: 70611, 70665, 70666