PHP 5.6.x < 5.6.3「donote」DoS

medium Nessus プラグイン ID 79248
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモート Web サーバーは、サービス拒否の脆弱性の影響を受けるバージョンの PHP を使用します。

説明

バナーによると、リモートホストにインストールされている PHP 5.6.x のバージョンは、5.6.3 より前です。このため、ファイル「ext/fileinfo/libmagic/readelf.c」内の関数「donote」での領域外読み取りエラーの影響を受けます。これにより、アプリケーションをクラッシュできることがあります。

Nessus はこれらの問題の悪用を試みていませんが、その代わりにアプリケーションの自己報告されたバージョン番号のみに依存していることに、注意してください。

ソリューション

PHP バージョン 5.6.3 または以降にアップグレードしてください。

関連情報

http://php.net/ChangeLog-5.php#5.6.3

https://bugs.php.net/bug.php?id=68283

http://www.nessus.org/u?6f0615b4

プラグインの詳細

深刻度: Medium

ID: 79248

ファイル名: php_5_6_3.nasl

バージョン: 1.3

タイプ: remote

ファミリー: CGI abuses

公開日: 2014/11/14

更新日: 2021/1/19

依存関係: php_version.nasl

リスク情報

CVSS スコアのソース: CVE-2014-3710

VPR

リスクファクター: Low

スコア: 3.6

CVSS v2

リスクファクター: Medium

Base Score: 5

Temporal Score: 3.7

ベクトル: AV:N/AC:L/Au:N/C:N/I:N/A:P

現状ベクトル: E:U/RL:OF/RC:C

脆弱性情報

CPE: cpe:/a:php:php

必要な KB アイテム: www/PHP

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2014/11/13

脆弱性公開日: 2014/11/13

参照情報

CVE: CVE-2014-3710

BID: 70807