Splunk Enterprise 6.0.x < 6.0.6の複数の脆弱性

medium Nessus プラグイン ID 79722

概要

リモートWebサーバーに、複数の脆弱性の影響を受けるアプリケーションが含まれています。

説明

バージョン番号によると、リモート Web サーバーでホストされている Splunk Enterprise は、6.0.6 より前の 6.0.x です。したがって、次の脆弱性の影響を受けます:

-付属の OpenSSL ライブラリに、TLS ダウングレードの脆弱性があります。中間者攻撃を行うリモートの攻撃者が、フラグメント化された ClientHello メッセージを使用することにより、強制的に TLS 1.0 にダウングレードさせることができます。(CVE-2014-3511)

- イベント解析時のユーザー指定の入力の不適切な検証により、クロスサイトスクリプティングの脆弱性が存在します。これにより、リモートの攻撃者は特別に細工されたリクエストを使用し、ユーザーのブラウザセッションで信頼関係がある範囲において、任意のスクリプトコードを実行することができます。
(CVE-2014-8303)

Nessusはこれらの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

Splunk Enterprise 6.0.6 または以降にアップグレードしてください。

関連情報

https://www.splunk.com/view/SP-CAAANHS

プラグインの詳細

深刻度: Medium

ID: 79722

ファイル名: splunk_606.nasl

バージョン: 1.10

タイプ: remote

ファミリー: CGI abuses

公開日: 2014/12/4

更新日: 2021/1/19

リスク情報

VPR

リスクファクター: Medium

スコア: 4.2

CVSS v2

リスクファクター: Medium

Base Score: 4.3

Temporal Score: 3.2

ベクトル: AV:N/AC:M/Au:N/C:N/I:P/A:N

現状ベクトル: E:U/RL:OF/RC:C

脆弱性情報

CPE: cpe:/a:splunk:splunk

必要な KB アイテム: installed_sw/Splunk

エクスプロイトの容易さ: No exploit is required

パッチ公開日: 2014/9/30

脆弱性公開日: 2014/8/6

参照情報

CVE: CVE-2014-3511, CVE-2014-8303

BID: 69079

CWE: 20, 74, 79, 442, 629, 711, 712, 722, 725, 750, 751, 800, 801, 809, 811, 864, 900, 928, 931, 990