Splunk Enterprise 6.0.x < 6.0.7 の複数の脆弱性(POODLE)

medium Nessus プラグイン ID 79723

概要

リモート Web サーバーに、複数の脆弱性の影響を受けるアプリケーションが、含まれています。

説明

バージョン番号によると、リモート Web サーバーでホストされている Splunk Enterprise は、6.0.7 より前の 6.0.x です。したがって、次の脆弱性の影響を受けます:

-中間者(MitM)情報漏洩の脆弱性(POODLE)の原因は、暗号ブロック連鎖(CBC)モードのブロック暗号を使用して暗号化されたメッセージを復号する際に、 SSL 3.0 がパディングバイトを処理する方法によるものです。被害を受けるアプリケーションに新たに作成した SSL 3.0 接続を通じて同じデータを繰り返し送信させることができる場合、MitM 攻撃者は、暗号テキスト内の選択したバイトをわずか 256 回の試行で復号できます。
(CVE-2014-3566)

- 付属の OpenSSL ライブラリに、整合性が適切に検証されてないセッションチケットの処理による欠陥があります。リモートの攻撃者は、大量の無効なセッションチケットを使用することで、これを悪用してサービス拒否を引き起こすことができます。(CVE-2014-3567)

- 入力の検証が不適切なため、ダッシュボードにクロスサイトスクリプティング欠陥が存在します。これにより、リモートの攻撃者は特別に細工されたリクエストを使用し、ユーザーのブラウザセッションで信頼関係がある範囲において、任意のスクリプトコードを実行することができます。(CVE-2014-5466)

Nessus はこれらの問題に対してテストされていませんが、その代わりにアプリケーションの自己報告されたバージョン番号のみに依存していることに、注意してください。

ソリューション

Splunk Enterprise 6.0.7 または以降にアップグレードしてください。

関連情報

https://www.splunk.com/view/SP-CAAANST

https://www.imperialviolet.org/2014/10/14/poodle.html

https://www.openssl.org/~bodo/ssl-poodle.pdf

https://tools.ietf.org/html/draft-ietf-tls-downgrade-scsv-00

プラグインの詳細

深刻度: Medium

ID: 79723

ファイル名: splunk_607.nasl

バージョン: 1.16

タイプ: remote

ファミリー: CGI abuses

公開日: 2014/12/4

更新日: 2021/1/19

リスク情報

VPR

リスクファクター: Medium

スコア: 5.3

CVSS v2

リスクファクター: Medium

Base Score: 4.3

Temporal Score: 3.2

ベクトル: AV:N/AC:M/Au:N/C:N/I:P/A:N

現状ベクトル: E:U/RL:OF/RC:C

CVSS スコアのソース: CVE-2014-5466

脆弱性情報

CPE: cpe:/a:splunk:splunk

必要な KB アイテム: installed_sw/Splunk

エクスプロイトの容易さ: No exploit is required

パッチ公開日: 2014/11/19

脆弱性公開日: 2014/10/14

参照情報

CVE: CVE-2014-3566, CVE-2014-3567, CVE-2014-5466

BID: 70574, 70586, 71257

CERT: 577193

CWE: 20, 74, 79, 442, 629, 711, 712, 722, 725, 750, 751, 800, 801, 809, 811, 864, 900, 928, 931, 990