PHP 5.5.x < 5.5.20「process_nested_data」RCE

high Nessus プラグイン ID 80331
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモート Web サーバーが使用するバージョンの PHP は、リモートコード実行脆弱性の影響を受けます。

説明

バナーによると、リモートホストにインストールされている PHP 5.5.x のバージョンは、5.5.20 より前です。このため、「ext/standard/var_unserializer.re」内の「process_nested_data」関数での use-after-free エラーによる影響を受けます。これは、シリアル化されたオブジェクトのプロパティ内で、重複するキーを不適切に処理しているため発生しています。リモートの攻撃者は、この欠陥を悪用して、特別に細工された「unserialize」メソッドへの呼び出しを使用することで、システムで任意のコードを実行することができます。

Nessus はこの問題を悪用しようとしていませんが、代わりにアプリケーションの自己報告バージョン番号のみに依存していますので注意してください。

ソリューション

PHP バージョン 5.5.20 または以降にアップグレードしてください。

関連情報

http://php.net/ChangeLog-5.php#5.5.20

https://bugs.php.net/bug.php?id=68594

http://www.nessus.org/u?88c4ed71

プラグインの詳細

深刻度: High

ID: 80331

ファイル名: php_5_5_20.nasl

バージョン: 1.11

タイプ: remote

ファミリー: CGI abuses

公開日: 2015/1/2

更新日: 2021/1/19

依存関係: php_version.nasl

リスク情報

VPR

リスクファクター: Medium

スコア: 6.6

CVSS v2

リスクファクター: High

Base Score: 7.5

Temporal Score: 5.5

ベクトル: AV:N/AC:L/Au:N/C:P/I:P/A:P

現状ベクトル: E:U/RL:OF/RC:C

脆弱性情報

CPE: cpe:/a:php:php

必要な KB アイテム: www/PHP

エクスプロイトの容易さ: No exploit is required

パッチ公開日: 2014/12/18

脆弱性公開日: 2014/12/18

参照情報

CVE: CVE-2014-8142

BID: 71791