PHP 5.5.x < 5.5.21 の複数の脆弱性

critical Nessus プラグイン ID 81081
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモート Web サーバーは、複数の脆弱性の影響を受ける PHP バージョンを使用しています。

説明

バナーによると、リモートホストにインストールされている PHP 5.5.x のバージョンは、5.5.21 より前です。そのため、以下の複数の脆弱性の影響を受けます。

- ハッシュ文字(#)で始まり、改行文字がない無効なファイルを、nmap を使用して処理する場合、ファイル「cgi_main.c」に領域外の読み取りの欠陥が存在します。
リモートの攻撃者が、この脆弱性を悪用して、特別に細工された PHP ファイルを使用することで、メモリの内容を漏洩したり、サービス拒否を引き起こしたり、任意のコードを実行したりする可能性があります。(CVE-2014-9427)

- 「gd_gif_in.c」の GetCode_() 関数に、領域外の読み取りの問題が存在します。これにより、リモートの攻撃者が、メモリの内容を漏洩する可能性があります。(CVE-2014-9709)

- 「var_unserializer.re」の process_nested_data() 関数に、use-after-free のメモリエラーが存在します。これは、シリアル化されたオブジェクトのプロパティ内で、重複する数値キーを不適切に処理しているため発生しています。リモートの攻撃者が、この脆弱性を悪用して、シリアル化を解除した細工されたメソッド呼び出しを使用することで、任意のコードを実行する可能性があります。
(CVE-2015-0231)

- 「exif.c」の exif_process_unicode() 関数に欠陥が存在し、初期化されていないポインターが解放される可能性があります。リモートの攻撃者が、これを悪用して、JPEG 画像の特別に細工された EXIF データを使用することで、サービス拒否を引き起こしたり、任意のコードを実行したりする可能性があります。(CVE-2015-0232)

Nessus はこれらの問題の悪用を試みていませんが、その代わりにアプリケーションの自己報告されたバージョン番号のみに依存していることに、注意してください。

ソリューション

PHP バージョン 5.5.21 または以降にアップグレードしてください。

関連情報

http://php.net/ChangeLog-5.php#5.5.21

https://bugs.php.net/bug.php?id=68618

https://bugs.php.net/bug.php?id=68710

https://bugs.php.net/bug.php?id=68799

プラグインの詳細

深刻度: Critical

ID: 81081

ファイル名: php_5_5_21.nasl

バージョン: 1.19

タイプ: remote

ファミリー: CGI abuses

公開日: 2015/1/29

更新日: 2021/1/19

依存関係: php_version.nasl

リスク情報

CVSS スコアのソース: CVE-2015-0231

VPR

リスクファクター: Medium

スコア: 6.7

CVSS v2

リスクファクター: High

Base Score: 7.5

Temporal Score: 5.5

ベクトル: AV:N/AC:L/Au:N/C:P/I:P/A:P

現状ベクトル: E:U/RL:OF/RC:C

CVSS v3

リスクファクター: Critical

Base Score: 9.8

Temporal Score: 8.5

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: cpe:/a:php:php

必要な KB アイテム: www/PHP

エクスプロイトの容易さ: No exploit is required

パッチ公開日: 2015/1/22

脆弱性公開日: 2014/12/17

参照情報

CVE: CVE-2014-9425, CVE-2014-9427, CVE-2014-9652, CVE-2014-9709, CVE-2015-0231, CVE-2015-0232

BID: 71800, 71833, 72505, 72539, 72541, 73306