Apache Tomcat 7.0.x < 7.0.57 の複数の脆弱性(POODLE)

high Nessus プラグイン ID 81650
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモートのApache Tomcatサーバーは、複数の脆弱性の影響を受けます。

説明

自己報告されたバージョン番号によると、リモートホストでリッスンしている Apache Tomcat サービスは、バージョン 7.0.x の 7.0.57 より前です。したがって、次の脆弱性の影響を受けます:

- DTLSパケットの処理に関連するメモリ二重解放のエラーが「d1_both.c」に存在することで、サービス拒否攻撃のおそれがあります。(CVE-2014-3505)

- 「d1_both.c」に、DTLSハンドシェイクメッセージの処理に関連する未特定のエラーが存在するため、大量のメモリ消費によるサービス拒否攻撃のおそれがあります。(CVE-2014-3506)

- 「d1_both.c」に、特別に作り上げられた DTLS パケットの処理に関連するメモリ漏洩エラーが存在するため、サービス拒否攻撃のおそれがあります。(CVE-2014-3507)

(CVE-2014-3508) - さまざまな「X509_name_*」プリティプリント関数が使用される場合に「OBJ_obj2txt」関数にエラーが存在することにより、プロセススタックデータが漏洩し、情報漏洩が発生します。

- 「ec point format extension」の処理およびマルチスレッド化されたクライアントに関連するエラーがあることにより、再開されたセッション中に、解放されたメモリに上書きできます。
(CVE-2014-3509)

- 匿名のECDH暗号パッケージおよび作り上げられたハンドシェイクメッセージの処理に関連するNULLポインターデリファレンスエラーが存在することにより、クライアントに対してサービス拒否攻撃を実行できます。(CVE-2014-3510)

- フラグメント化された「ClientHello」メッセージの処理に関連するエラーがあることにより、中間攻撃者は、サーバーとクライアントの両方でより高いレベルのプロトコルがサポートされているかとは無関係に、TLS 1.0の使用を強制できます。(CVE-2014-3511)

- 「srp_lib.c」に、セキュアリモートパスワードプロトコル(SRP)パラメータの処理に関連するバッファオーバーフローエラーが存在することにより、サービス拒否をすることや、他の未特定の影響を与えることができる可能性があります。(CVE-2014-3512)

- 「d1_srtp.c」に、DTLS SRTP拡張処理および特別に細工されたハンドシェイクメッセージに関連するメモリリークの問題があるために、サービス拒否攻撃のおそれがあります。(CVE-2014-3513)

- 暗号ブロック連鎖(CBC)モードのブロック暗号を使って暗号化されたメッセージを復号するときに、SSL 3.0 が適切にパディングバイトを処理する方法に関連するエラーが存在します。
新たに作成した SSL 3.0 接続を通じて被害者のアプリケーションに同じデータを繰り返し送信させることができる場合、中間攻撃者は、暗号テキスト内の選択したバイトをわずか 256 回の試行で復号できます。これは「POODLE」問題としても知られています。(CVE-2014-3566)

- 「t1_lib.c」に、セッションチケット処理に関連するメモリリークの問題があるために、サービス拒否攻撃のおそれがあります。(CVE-2014-3567)

- ビルド構成プロセスおよび「no-ssl3」ビルドオプションに関連するエラーがあることにより、サーバーおよびクライアントでセキュアでないSSL 3.0ハンドシェイクメッセージを処理できます。(CVE-2014-3568)

- 「t1_lib.c」に、セキュアリモートパスワード(SRP)プロトコルのServerHelloメッセージの処理に関連するNULLポインターデリファレンスエラーがあることにより、悪意のあるサーバーがクライアントをクラッシュさせて、サービス拒否を引き起こす可能性があります。(CVE-2014-5139)

Nessusはこれらの問題を悪用したことはありませんが、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

Apache Tomcat バージョン 7.0.57 または以降に更新してください。

関連情報

http://tomcat.apache.org/tomcat-7.0-doc/changelog.html

https://www.imperialviolet.org/2014/10/14/poodle.html

https://www.openssl.org/~bodo/ssl-poodle.pdf

https://tools.ietf.org/html/draft-ietf-tls-downgrade-scsv-00

プラグインの詳細

深刻度: High

ID: 81650

ファイル名: tomcat_7_0_57.nasl

バージョン: 1.10

タイプ: combined

エージェント: windows, macosx, unix

ファミリー: Web Servers

公開日: 2015/3/5

更新日: 2020/7/22

依存関係: tomcat_error_version.nasl, tomcat_win_installed.nbin, apache_tomcat_nix_installed.nbin, os_fingerprint.nasl

リスク情報

CVSS スコアのソース: CVE-2014-3505

VPR

リスクファクター: Medium

スコア: 5.9

CVSS v2

リスクファクター: High

Base Score: 7.5

Temporal Score: 5.5

ベクトル: AV:N/AC:L/Au:N/C:P/I:P/A:P

現状ベクトル: E:U/RL:OF/RC:C

CVSS v3

リスクファクター: High

Base Score: 7.3

Temporal Score: 6.4

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: cpe:/a:apache:tomcat

必要な KB アイテム: installed_sw/Apache Tomcat

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2014/11/11

脆弱性公開日: 2014/8/6

参照情報

CVE: CVE-2014-3505, CVE-2014-3506, CVE-2014-3507, CVE-2014-3508, CVE-2014-3509, CVE-2014-3510, CVE-2014-3511, CVE-2014-3512, CVE-2014-3513, CVE-2014-3566, CVE-2014-3567, CVE-2014-3568, CVE-2014-5139

BID: 69075, 69076, 69077, 69078, 69079, 69081, 69082, 69083, 69084, 70574, 70584, 70585, 70586

CERT: 577193