phpMyAdmin 4.0.x < 4.0.10.9/4.2.x < 4.2.13.2/4.3.x < 4.3.11.1の情報漏洩の脆弱性(PMASA-2015-1)

medium Nessus プラグイン ID 81818
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモート Web サーバーは、情報漏洩の脆弱性により影響を受ける PHP アプリケーションをホストしています。

説明

自己報告されたバージョン番号によると、リモートの Web サーバーでホストされている phpMyAdmin アプリケーションは、4.0.10.9 より前の 4.0.x、4.2.13.2 より前の 4.2.x、または 4.3.11.1 より前の 4.3.x です。このため、圧縮された HTTPS 応答の長さが隠されていないため、情報漏洩の脆弱性の影響を受けます。これにより、リモートの攻撃者は、細工された一連のリクエストを使用することで、BREACH 攻撃を通じて、CSRF トークンを入手することができます。

Nessusはこの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

phpMyAdmin 4.0.10.9 / 4.2.13.2 / 4.3.11.1 以降にアップグレードするか、ベンダーアドバイザリで参照されているパッチを適用してください。

関連情報

http://www.phpmyadmin.net/home_page/security/PMASA-2015-1.php

http://www.nessus.org/u?a4cc2198

http://www.nessus.org/u?11d0e38d

http://www.nessus.org/u?4b01e679

プラグインの詳細

深刻度: Medium

ID: 81818

ファイル名: phpmyadmin_pmasa_2015_1.nasl

バージョン: 1.5

タイプ: remote

ファミリー: CGI abuses

公開日: 2015/3/13

更新日: 2021/1/19

依存関係: phpMyAdmin_detect.nasl

構成: パラノイドモードの有効化

リスク情報

VPR

リスクファクター: Low

スコア: 2.5

CVSS v2

リスクファクター: Medium

Base Score: 5

Temporal Score: 3.7

ベクトル: AV:N/AC:L/Au:N/C:P/I:N/A:N

現状ベクトル: E:U/RL:OF/RC:C

脆弱性情報

CPE: cpe:/a:phpmyadmin:phpmyadmin

必要な KB アイテム: www/PHP, installed_sw/phpMyAdmin, Settings/ParanoidReport

エクスプロイトの容易さ: No exploit is required

パッチ公開日: 2015/3/4

脆弱性公開日: 2015/3/4

参照情報

CVE: CVE-2015-2206

BID: 72949