Mandriva Linux セキュリティアドバイザリ:gnupg(MDVSA-2015:154)

medium Nessus プラグイン ID 82407

概要

リモート Mandriva Linux ホストには、1 つ以上のセキュリティ更新がありません。

説明

更新済みの gnupg、gnupg2 および libgcrypt パッケージにより、セキュリティの脆弱性が修正されます:

1.4.17 および 2.0.24 以前のバージョンの GnuPG は、サービス拒否に脆弱です。このサービス拒否は、無限ループに gpg を陥れる可能性のある文字化けした圧縮データパケットにより発生します(CVE-2014-4617)。

バージョン 1.5.4 以前の libgcrypt ライブラリは、ELGAMAL サイドチャネル攻撃に対して脆弱です(CVE-2014-5270)。

GnuPG before 1.4.19 がサイドチャネル攻撃に脆弱で、情報漏洩が引き起こされる可能性があります(CVE-2014-3591)。

1.4.19 より前の GnuPG が冪剰余のデータ依存のタイミング変動でのサイドチャネル攻撃に脆弱なため、情報漏洩が発生する可能性があります(CVE-2015-0837)。

gnupg および gnupg2 パッケージには、これらの問題を修正するため、パッチが適用されました。

GnuPG2 は、libgcrypt ライブラリでこれらの問題に脆弱です。
この問題は libgcrypt 1.6.3 で修正されました。バージョン 1.5.4 の Mandriva の libgcrypt パッケージは、 CVE-2014-3591 の問題のみに脆弱です。この問題を修正するためにパッチも適用されています。

ソリューション

影響を受けるパッケージを更新してください。

関連情報

http://advisories.mageia.org/MGASA-2014-0276.html

http://advisories.mageia.org/MGASA-2014-0365.html

http://advisories.mageia.org/MGASA-2015-0104.html

プラグインの詳細

深刻度: Medium

ID: 82407

ファイル名: mandriva_MDVSA-2015-154.nasl

バージョン: 1.4

タイプ: local

公開日: 2015/3/30

更新日: 2021/1/14

リスク情報

VPR

リスクファクター: Low

スコア: 3.6

CVSS v2

リスクファクター: Medium

Base Score: 5

ベクトル: AV:N/AC:L/Au:N/C:N/I:N/A:P

脆弱性情報

CPE: p-cpe:/a:mandriva:linux:gnupg, p-cpe:/a:mandriva:linux:gnupg2, p-cpe:/a:mandriva:linux:lib64gcrypt-devel, p-cpe:/a:mandriva:linux:lib64gcrypt11, cpe:/o:mandriva:business_server:2

必要な KB アイテム: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

パッチ公開日: 2015/3/29

参照情報

CVE: CVE-2014-3591, CVE-2014-4617, CVE-2014-5270, CVE-2015-0837

MDVSA: 2015:154