RHEL 5:openssl(RHSA-2015:0800)(FREAK)

medium Nessus プラグイン ID 82758
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモート Red Hat ホストに 1 つ以上のセキュリティ更新がありません。

説明

複数のセキュリティの問題を修正する更新済みの openssl パッケージが、Red Hat Enterprise Linux 5 で現在利用可能です。

Red Hat 製品セキュリティは、この更新がセキュリティに及ぼす影響を重要度中として評価しています。詳細な重要度の評価を提供する Common Vulnerability Scoring System (CVSS)のベーススコアが、「参照」セクションの CVE リンクの各脆弱性に対して利用可能です。

OpenSSL は、Secure Sockets Layer(SSL v2/v3)および Transport Layer Security (TLS v1)プロトコル、ならびに全強度の汎用暗号化ライブラリを実装するツールキットです。

エクスポートされていない RSA 暗号化パッケージを使用するときに、OpenSSL がエフェメラル RSA キーを受け入れることが判明しました。悪意あるサーバーが、 OpenSSL を使用している TLS/SSL クライアントに、より脆弱なキー交換方法を使わせる可能性があります。
(CVE-2015-0204)

OpenSSL が無効な形式の Base64 エンコード入力をデコードする方法で、整数アンダーフローの欠陥が発見されています。これにより、バッファオーバーフローが引き起こされます。攻撃者が、OpenSSL デコードを使用するアプリケーションに特別に細工された Base64 エンコード入力(PEM ファイルなど)をデコードさせることができた場合、この欠陥を利用して、アプリケーションをクラッシュさせる可能性があります。転送されるデータが Base64 エンコードの処理を受けていないため、この欠陥を TLS/SSL プロトコルにより悪用することはできません。(CVE-2015-0292)

OpenSSL が SSLv2 ハンドシェイクメッセージを処理する方法で、サービス拒否の欠陥が見つかりました。SSLv2 プロトコルと EXPORT グレード暗号化パッケージの両方を有効にしている場合、リモートの攻撃者が、この欠陥を利用して、OpenSSL を使用する TLS/SSL サーバーを失敗したアサーションで終了させる可能性があります。
(CVE-2015-0293)

OpenSSL が X.509 証明書を解析する方法に、複数の欠陥が見つかりました。攻撃者が、これらの欠陥を利用して、 X.509 証明書を改竄することにより、署名を取り消さずに別の指紋が付いた証明書を作り出したり、アプリケーションで指紋ベースのブラックリストをバイパスしたりする可能性があります。(CVE-2014-8275)

OpenSSL が特定の ASN.1 構造体を再利用する方法で、領域外書き込みの欠陥が見つかりました。リモートの攻撃者が、特別に細工された ASN.1 構造体を使用する可能性があります。それをアプリケーションが解析した場合、そのアプリケーションがクラッシュします。(CVE-2015-0287)

NULL ポインターデリファレンスの欠陥が、OpenSSL の X.509 証明書処理の実装で見つかりました。特別に細工された X.509 証明書により、OpenSSL を使用するアプリケーションがその証明書を証明書リクエストに変換しようとするときに、そのアプリケーションがクラッシュする可能性があります。(CVE-2015-0288)

OpenSSL が特定の PKCS#7 入力を処理する方法で、 NULL ポインターデリファレンスが見つかっています。攻撃者が、OpenSSL を使用するアプリケーションに特別に細工された PKCS#7 入力を検証、復号、または解析させることができた場合、そのアプリケーションをクラッシュさせる可能性があります。OpenSSL を使用する TLS/SSL クライアントおよびサーバーは、この欠陥による影響を受けません。(CVE-2015-0289)

Red Hat は、CVE-2015-0287、CVE-2015-0288、CVE-2015-0289、CVE-2015-0292、および CVE-2015-0293 を報告してくれた OpenSSL プロジェクトに感謝の意を表します。Upstream は、OpenSSL 開発チームの Emilia Käsper 氏を CVE-2015-0287 の最初の報告者として、Brian Carpenter 氏を CVE-2015-0288 の最初の報告者として、Google の Michal Zalewski 氏を CVE-2015-0289 の最初の報告者として、Robert Dugal 氏および David Ramos 氏を CVE-2015-0292 の最初の報告者として、Google の Sean Burford 氏および OpenSSL 開発チームの Emilia Käsper 氏を CVE-2015-0293 の最初の報告者として認めます。。

openssl の全ユーザーは、バックポートされたパッチが含まれるこれらの更新済みパッケージへアップグレードし、これらの問題を修正することが推奨されます。更新を有効にするには、 OpenSSL ライブラリにリンクされているすべてのサービスを再起動するか、システムを再起動する必要があります。

ソリューション

影響を受けるパッケージを更新してください。

関連情報

https://www.openssl.org/news/secadv/20150108.txt

https://www.openssl.org/news/secadv/20150319.txt

https://access.redhat.com/articles/1384453

https://access.redhat.com/errata/RHSA-2015:0800

https://access.redhat.com/security/cve/cve-2016-0704

https://access.redhat.com/security/cve/cve-2016-0703

https://access.redhat.com/security/cve/cve-2015-0204

https://access.redhat.com/security/cve/cve-2014-8275

https://access.redhat.com/security/cve/cve-2015-0288

https://access.redhat.com/security/cve/cve-2015-0289

https://access.redhat.com/security/cve/cve-2015-0287

https://access.redhat.com/security/cve/cve-2015-0293

https://access.redhat.com/security/cve/cve-2015-0292

プラグインの詳細

深刻度: Medium

ID: 82758

ファイル名: redhat-RHSA-2015-0800.nasl

バージョン: 1.22

タイプ: local

エージェント: unix

公開日: 2015/4/14

更新日: 2019/10/24

依存関係: ssh_get_info.nasl

リスク情報

VPR

リスクファクター: Medium

スコア: 5.9

CVSS v2

リスクファクター: High

Base Score: 7.5

Temporal Score: 5.5

ベクトル: AV:N/AC:L/Au:N/C:P/I:P/A:P

現状ベクトル: E:U/RL:OF/RC:C

CVSS v3

リスクファクター: Medium

Base Score: 5.9

Temporal Score: 5.2

ベクトル: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: p-cpe:/a:redhat:enterprise_linux:openssl, p-cpe:/a:redhat:enterprise_linux:openssl-debuginfo, p-cpe:/a:redhat:enterprise_linux:openssl-devel, p-cpe:/a:redhat:enterprise_linux:openssl-perl, cpe:/o:redhat:enterprise_linux:5

必要な KB アイテム: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list, Host/cpu

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2015/4/13

参照情報

CVE: CVE-2014-8275, CVE-2015-0204, CVE-2015-0287, CVE-2015-0288, CVE-2015-0289, CVE-2015-0292, CVE-2015-0293, CVE-2016-0703, CVE-2016-0704

RHSA: 2015:0800