Adobe Flash Player <= 17.0.0.134 の複数の脆弱性(APSB15-06)

critical Nessus プラグイン ID 82782

概要

リモート Mac OS X ホストには、複数の脆弱性による影響を受けるブラウザプラグインがインストールされています。

説明

リモート Mac OS X ホストにインストールされている Adobe Flash Player のバージョンは、 17.0.0.134 以前です。したがって、以下の複数の脆弱性による影響を受けます:

- 複数の二重解放エラーが存在し、これにより、攻撃者が任意のコードを実行する可能性があります。(CVE-2015-0346、 CVE-2015-0359)

- ユーザー指定入力の不適当な検証により、複数の詳細不明なメモリ破損の欠陥が存在します。リモートの攻撃者が、特別に細工されたフラッシュコンテンツにより、これらの欠陥を悪用し、メモリを破損させたり、任意のコードを実行したりする可能性があります。
(CVE-2015-0347、CVE-2015-0350、CVE-2015-0352、CVE-2015-0353、CVE-2015-0354、CVE-2015-0355、CVE-2015-0360、CVE-2015-3038、CVE-2015-3041、CVE-2015-3042、CVE-2015-3043)

- ユーザー指定入力の不適切な検証により、詳細不明なバッファオーバーフロー状態が存在します。リモートの攻撃者がこれを悪用し、任意のコードを実行する恐れがあります。
(CVE-2015-0348)

- 複数の特定されない use-after-free エラーが存在するため、攻撃者が任意のコードを実行する可能性があります。
(CVE-2015-0349、CVE-2015-0351、CVE-2015-0358、 CVE-2015-3039)

- 詳細不明な型の取り違え(Type Confusion)の欠陥が存在するため、攻撃者は任意のコードを実行できます。(CVE-2015-0356)

- 攻撃者にアドレス空間配置のランダム化(ASLR)機能のバイパスを可能にさせる複数の詳細不明のメモリリークが存在します。(CVE-2015-0357、 CVE-2015-3040)

- 攻撃者に情報の漏洩を可能にさせる詳細不明のセキュリティバイパス欠陥が存在します。(CVE-2015-3044)

ソリューション

Adobe Flash バージョン 17.0.0.169 または以降にアップグレードしてください。

または、17.x にアップグレードできないインストール用に、Adobe はバージョン 13.0.0.281 および 11.2.202.457 を用意しています。

関連情報

https://helpx.adobe.com/security/products/flash-player/apsb15-06.html

http://www.nessus.org/u?0cb17c10

プラグインの詳細

深刻度: Critical

ID: 82782

ファイル名: macosx_flash_player_apsa15-06.nasl

バージョン: 1.17

タイプ: local

エージェント: macosx

公開日: 2015/4/14

更新日: 2022/3/8

サポートされているセンサー: Nessus Agent

リスク情報

CVSS スコアのソース: CVE-2015-3043

VPR

リスクファクター: Critical

スコア: 9.6

CVSS v2

リスクファクター: Critical

Base Score: 10

Temporal Score: 8.7

ベクトル: AV:N/AC:L/Au:N/C:C/I:C/A:C

現状ベクトル: E:H/RL:OF/RC:C

脆弱性情報

CPE: cpe:/a:adobe:flash_player

必要な KB アイテム: MacOSX/Flash_Player/Version

エクスプロイトが利用可能: true

エクスプロイトの容易さ: Exploits are available

パッチ公開日: 2015/4/14

脆弱性公開日: 2015/4/14

CISAの既知の悪用日: 2022/3/24

エクスプロイト可能

Core Impact

Metasploit (Adobe Flash Player domainMemory ByteArray Use After Free)

参照情報

CVE: CVE-2015-0346, CVE-2015-0347, CVE-2015-0348, CVE-2015-0349, CVE-2015-0350, CVE-2015-0351, CVE-2015-0352, CVE-2015-0353, CVE-2015-0354, CVE-2015-0355, CVE-2015-0356, CVE-2015-0357, CVE-2015-0358, CVE-2015-0359, CVE-2015-0360, CVE-2015-3038, CVE-2015-3039, CVE-2015-3040, CVE-2015-3041, CVE-2015-3042, CVE-2015-3043, CVE-2015-3044

BID: 74062, 74064, 74065, 74066, 74067, 74068, 74069