PHP 5.4.x < 5.4.40 の複数の脆弱性

critical Nessus プラグイン ID 83033
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモート Web サーバーは、複数の脆弱性の影響を受ける PHP バージョンを使用しています。

説明

バナーによると、リモート Web サーバーで実行している PHP 5.4.x のバージョンは、5.4.40 より前です。したがって、以下の複数の脆弱性による影響を受けます:

- 「gd_gif_in.c」ファイルの GetCode_() 関数での領域外読み取りオーバーフローエラーにより、DoS 攻撃(サービス拒否攻撃)またはメモリ内容の漏洩の可能性があります。(CVE-2014-9709)

- PostgreSQL 拡張の「pgsql.c」ファイルにある build_tablename() 関数が、テーブル名に対するトークンを適切に検証していません。細工された名前を使用するリモートの攻撃者が、これを悪用し、サービス拒否を発生させる NULL ポインターデリファレンスを引き起こす可能性があります。
(CVE-2015-1352)

- 「phar_object.c」ファイルの phar_rename_archive() 関数に、use-after-free エラーが存在します。リモートの攻撃者が、phar アーカイブの名前を既に存在するファイル名に変更しようとすることにより、これを悪用し、サービス拒否を引き起こす可能性があります。(CVE-2015-2301)

- unserialize() 関数の呼び出し中に phar の解析を処理する際、ユーザーが指定した入力が適切に検証されていません。このため、phar コンポーネントに、バッファ読み込みオーバーフローのエラーが存在します。攻撃者がこれを悪用して、任意のコードを実行したり、サービス拒否を引き起こす可能性があります。
(CVE-2015-2783)

- tar、zip、phar のファイルのアーカイブを処理する際、' 「phar_internal.h」ファイルの phar_set_inode() 関数にバッファオーバーフローの欠陥が存在します。リモートの攻撃者が、これを悪用し、任意のコードの実行やサービス拒否を引き起こす可能性があります。(CVE-2015-3329)

- パイプライン化されている HTTP リクエストを処理する際、Apache2handler SAPI コンポーネントに欠陥が存在し、リモートの攻撃者が任意のコードを実行するためにこれを悪用する可能性があります。(CVE-2015-3330)

- ユーザー指定入力の不適当な検証により、複数の詳細不明なメモリ破損の欠陥が存在します。リモートの攻撃者が、これらの問題を悪用し、サービス拒否の状態を引き起こす可能性があります。(CVE-2015-4601)

- ユーザーが指定した入力が不適切に検証されているため、incomplete_class.c にメモリ破損の欠陥が存在します。リモートの攻撃者が、この欠陥を悪用し、機密情報を漏洩したり、サービス拒否の状態を引き起こしたりする可能性があります。(CVE-2015-4602)

- 「exception::getTraceAsString'」にある特定されない欠陥により、サービス拒否の脆弱性が存在します。リモートの攻撃者が、この欠陥を悪用し、アプリケーションをクラッシュさせる可能性があります。(CVE-2015-4603)

- softmagic.c のバンドルされている libmagic ライブラリに、サービス拒否の脆弱性が存在します。リモートの攻撃者が、これを悪用し、アプリケーションをクラッシュさせる可能性があります。
(CVE-2015-4604)

- softmagic.c. の mcopy() 関数にあるバンドルされた libmagic ライブラリに欠陥があるため、サービス拒否の脆弱性が存在します。この関数は、「bytecnt」を超えるオフセットを適切に処理するのに失敗します。リモートの攻撃者が、細工された文字列でこれを悪用し、サービス拒否の状態を引き起こす可能性があります。(CVE-2015-4605)

Nessus はこれらの問題の悪用を試みていませんが、その代わりにアプリケーションの自己報告されたバージョン番号のみに依存していることに、注意してください。

ソリューション

PHP バージョン 5.4.40 または以降にアップグレードしてください。

関連情報

http://php.net/ChangeLog-5.php#5.4.40

プラグインの詳細

深刻度: Critical

ID: 83033

ファイル名: php_5_4_40.nasl

バージョン: 1.19

タイプ: remote

ファミリー: CGI abuses

公開日: 2015/4/23

更新日: 2021/1/19

依存関係: php_version.nasl

リスク情報

VPR

リスクファクター: Medium

スコア: 6.7

CVSS v2

リスクファクター: Critical

Base Score: 10

Temporal Score: 7.4

ベクトル: AV:N/AC:L/Au:N/C:C/I:C/A:C

現状ベクトル: E:U/RL:OF/RC:C

CVSS v3

リスクファクター: Critical

Base Score: 9.8

Temporal Score: 8.5

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: cpe:/a:php:php

必要な KB アイテム: www/PHP

エクスプロイトの容易さ: No exploit is required

パッチ公開日: 2015/4/16

脆弱性公開日: 2014/12/13

参照情報

CVE: CVE-2014-9709, CVE-2015-1352, CVE-2015-2301, CVE-2015-2783, CVE-2015-3307, CVE-2015-3329, CVE-2015-3330, CVE-2015-3411, CVE-2015-3412, CVE-2015-4599, CVE-2015-4600, CVE-2015-4601, CVE-2015-4602, CVE-2015-4603, CVE-2015-4604, CVE-2015-4605

BID: 71932, 73037, 73306, 74204, 74239, 74240, 74413, 74703, 75233, 75241, 75246, 75249, 75250, 75251, 75252, 75255