PHP 5.4.x < 5.4.41 の複数の脆弱性

critical Nessus プラグイン ID 83517
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモート Web サーバーは、複数の脆弱性の影響を受ける PHP バージョンを使用しています。

説明

バナーによると、リモート Web サーバーで実行している PHP 5.4.x のバージョンは、5.4.41 より前です。したがって、以下の複数の脆弱性による影響を受けます:

- - NULL バイトを含まれているパス名の使用に関連する複数の欠陥が存在します。リモートの攻撃者、’\0’文字列を安全なファイル拡張機能と組み合わせることでこの欠陥を悪用し、アクセス制限をバイパスする恐れがあります。これは以前修正されましたが、バージョン 5.4+ での回帰により再度発生しました。(CVE-2006-7243、 CVE-2015-4025)

- HTTP リクエストでマルチパート/フォームデータを不適切に処理しているため、rfc1867.c 内の multipart_buffer_headers() 関数に欠陥が存在します。リモートの攻撃者がこの欠陥を悪用し、サービス拒否状態につながるCPU リソースの消費を引き起こす恐れがあります。
(CVE-2015-4024)

- 「\x00」文字があるとパス名を切り捨てる pcntl_exec 実装に欠陥があることが原因で、セキュリティバイパス脆弱性が存在します。リモートの攻撃者が細工された最初の引数を介してこれを悪用し、意図された拡張制限をバイパスし任意のファイルを実行する恐れがあります。(CVE-2015-4026)

Nessus は、この問題をテストしていませんが、その代わりにアプリケーションの自己報告されたバージョン番号のみに依存していることに、注意してください。

ソリューション

PHP バージョン 5.4.41 または以降にアップグレードしてください。

関連情報

http://php.net/ChangeLog-5.php#5.4.41

プラグインの詳細

深刻度: Critical

ID: 83517

ファイル名: php_5_4_41.nasl

バージョン: 1.12

タイプ: remote

ファミリー: CGI abuses

公開日: 2015/5/18

更新日: 2021/1/19

依存関係: php_version.nasl

リスク情報

CVSS スコアのソース: CVE-2015-4026

VPR

リスクファクター: Medium

スコア: 5.9

CVSS v2

リスクファクター: High

Base Score: 7.5

Temporal Score: 5.5

ベクトル: AV:N/AC:L/Au:N/C:P/I:P/A:P

現状ベクトル: E:U/RL:OF/RC:C

CVSS v3

リスクファクター: Critical

Base Score: 9.8

Temporal Score: 8.5

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: cpe:/a:php:php

必要な KB アイテム: www/PHP

エクスプロイトの容易さ: No exploit is required

パッチ公開日: 2015/5/14

脆弱性公開日: 2006/12/18

参照情報

CVE: CVE-2006-7243, CVE-2015-2325, CVE-2015-2326, CVE-2015-4021, CVE-2015-4022, CVE-2015-4024, CVE-2015-4025, CVE-2015-4026

BID: 44951, 74700, 74902, 74903, 74904, 75056, 75174, 75175