Squid 3.2 < 3.5.4 X509 サーバー証明書の不適切な検証の脆弱性

low Nessus プラグイン ID 83529
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモートの proxy サーバーは、証明書検証の脆弱性による影響を受ける可能性があります。

説明

バナーによると、リモートホストで実行中の Squid のバージョンは、3.2.14/3.3.14/3.4.13/3.5.4 より前の 3.2 です。このため、証明書の検証に関連する欠陥の影響を受けます。これは、サーバーのホスト名が、証明書のサブジェクトのコモンネーム(CN)フィールドまたは SubjectAltName フィールドのドメイン名と一致していることが検証されないことが原因です。中間者攻撃の攻撃者がこれを利用して、細工された証明書を使用することで、TLS/SSL サーバーになりすますことができるため、傍受したデータの漏洩または操作が可能になります。注意:この欠陥を悪用できるのは、SSL Bumping を「client-first」または「bump」の操作モードで実行するように Squid が構成された場合のみです。

Nessus は、この問題をテストしていませんが、その代わりにアプリケーションの自己報告されたバージョン番号のみに依存していることに、注意してください。この問題に対処するためにリリースされたパッチでは、バナーのバージョンは更新されません。このパッチが適切に適用され、サービスが再起動された場合には、これが偽陽性であると見なしてください。

ソリューション

Squid をバージョン 3.2.14/3.3.14/3.4.13/3.5.4 以降にアップグレードするか、またはベンダーが提供するパッチを適用してください。

関連情報

http://www.squid-cache.org/Advisories/

http://www.squid-cache.org/Advisories/SQUID-2015_1.txt

http://www.nessus.org/u?8ef2aa9b

プラグインの詳細

深刻度: Low

ID: 83529

ファイル名: squid_3_5_4.nasl

バージョン: 1.4

タイプ: remote

ファミリー: Firewalls

公開日: 2015/5/19

更新日: 2019/11/22

依存関係: squid_version.nasl

構成: パラノイドモードの有効化

リスク情報

CVSS スコアのソース: CVE-2015-3455

VPR

リスクファクター: Low

スコア: 3.6

CVSS v2

リスクファクター: Low

Base Score: 2.6

Temporal Score: 1.9

ベクトル: AV:N/AC:H/Au:N/C:N/I:P/A:N

現状ベクトル: E:U/RL:OF/RC:C

脆弱性情報

CPE: cpe:/a:squid-cache:squid

必要な KB アイテム: www/squid, Settings/ParanoidReport

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2015/5/1

脆弱性公開日: 2015/5/1

参照情報

CVE: CVE-2015-3455

BID: 74438