OpenSSL 0.9.8 < 0.9.8zg の複数の脆弱性

medium Nessus プラグイン ID 84151

概要

リモートサービスは、複数の脆弱性の影響を受けます。

説明

バナーによると、リモート Web サーバーで 0.9.8zg より前のバージョンの OpenSSL 0.9.8 が使用されています。このため、OpenSSL ライブラリは、以下の脆弱性の影響を受けます。

- 指定された曲線が無効なバイナリ多項式フィールドを超えたときに発生する無限ループにより、ECParameters 構造体の処理時にサービス拒否の脆弱性が存在します。リモートの攻撃者はこれを悪用して公開鍵、証明書リクエストまたは証明書を処理するシステムすべてに対してサービス拒否を行うことができます。これには、クライアント認証の有効化された TLS クライアントや TLS サーバーが含まれます。(CVE-2015-1788)

- X509_cmp_time() 関数による ASN1_TIME 文字列のコンテンツと長さの不適切な検証による、サービス拒否の脆弱性が存在します。リモートの攻撃者はこれを悪用して、無効な形式の証明書や様々なサイズの CRL から、セグメンテーション違反を起こすことができます。これにより、サービス拒否状態が発生します。CRL を検証する TLS クライアントが影響を受けます。
クライアント認証が有効化されている TLS クライアントおよびサーバーはカスタム検証コールバックを使用すると、影響を受ける可能性があります。(CVE-2015-1789)

- 欠如している内部「EncryptedContent」の不適切な処理により、PKCS#7 解析コードに、NULL ポインターデリファレンスの欠陥が存在しています。これにより、リモートの攻撃者は特別に細工された、コンテンツの欠如した ASN.1 エンドコード PKCS#7 blob からサービス拒否状態を起こすことや、その他の詳細不明な影響を与えることがあります。(CVE-2015-1790)

- 以前のチケットの再利用を試行するとき NewSessionTicket がマルチスレッドクライアントによって受信される際に発生する競合状態により、二重解放エラーが存在しています。(CVE-2015-1791)

- signedData メッセージを検証する際に発生する無限ループにより、CMS コードにサービス拒否の脆弱性が存在しています。リモートの攻撃者がこれを悪用することで、サービス拒否状態を引き起こす可能性があります。(CVE-2015-1792)

ソリューション

OpenSSL 0.9.8gz または以降にアップグレードしてください。

関連情報

https://www.openssl.org/news/secadv/20150611.txt

プラグインの詳細

深刻度: Medium

ID: 84151

ファイル名: openssl_0_9_8zg.nasl

バージョン: 1.7

タイプ: remote

ファミリー: Web Servers

公開日: 2015/6/12

更新日: 2019/1/2

リスク情報

VPR

リスクファクター: Medium

スコア: 5.9

CVSS v2

リスクファクター: Medium

Base Score: 6.8

Temporal Score: 5

ベクトル: AV:N/AC:M/Au:N/C:P/I:P/A:P

現状ベクトル: E:U/RL:OF/RC:C

脆弱性情報

CPE: cpe:/a:openssl:openssl

必要な KB アイテム: openssl/port

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2015/6/11

脆弱性公開日: 2015/6/11

参照情報

CVE: CVE-2015-1788, CVE-2015-1789, CVE-2015-1790, CVE-2015-1791, CVE-2015-1792

BID: 75154, 75156, 75157, 75158, 75161