Amazon Linux AMI:php54(ALAS-2015-561)

critical Nessus プラグイン ID 84623
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモート Amazon Linux AMI ホストに、セキュリティ更新がありません。

説明

Upstream は、バンドルされた sqlite ライブラリのいくつかのセキュリティ問題と共に、6 つの PHP のセキュリティ関連の問題がこのリリースで修正されたと報告しています(CVE-2015-3414、CVE-2015-3415、CVE-2015-3416)。PHP 5.4 の全ユーザーは、このバージョンにアップグレードすることが推奨されます。詳細については、 Upstream リリースノートを参照してください。

ソリューション

「yum update php54」を実行してシステムを更新してください。

関連情報

http://php.net/ChangeLog-5.php#5.4.42

https://alas.aws.amazon.com/ALAS-2015-561.html

プラグインの詳細

深刻度: Critical

ID: 84623

ファイル名: ala_ALAS-2015-561.nasl

バージョン: 2.6

タイプ: local

エージェント: unix

公開日: 2015/7/9

更新日: 2018/4/18

依存関係: ssh_get_info.nasl

リスク情報

VPR

リスクファクター: Medium

スコア: 5.9

CVSS v2

リスクファクター: Critical

Base Score: 10

ベクトル: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

CVSS v3

リスクファクター: Critical

Base Score: 9.8

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

脆弱性情報

CPE: cpe:2.3:o:amazon:linux:*:*:*:*:*:*:*:*, p-cpe:2.3:a:amazon:linux:php54:*:*:*:*:*:*:*, p-cpe:2.3:a:amazon:linux:php54-bcmath:*:*:*:*:*:*:*, p-cpe:2.3:a:amazon:linux:php54-cli:*:*:*:*:*:*:*, p-cpe:2.3:a:amazon:linux:php54-common:*:*:*:*:*:*:*, p-cpe:2.3:a:amazon:linux:php54-dba:*:*:*:*:*:*:*, p-cpe:2.3:a:amazon:linux:php54-debuginfo:*:*:*:*:*:*:*, p-cpe:2.3:a:amazon:linux:php54-devel:*:*:*:*:*:*:*, p-cpe:2.3:a:amazon:linux:php54-embedded:*:*:*:*:*:*:*, p-cpe:2.3:a:amazon:linux:php54-enchant:*:*:*:*:*:*:*, p-cpe:2.3:a:amazon:linux:php54-fpm:*:*:*:*:*:*:*, p-cpe:2.3:a:amazon:linux:php54-gd:*:*:*:*:*:*:*, p-cpe:2.3:a:amazon:linux:php54-imap:*:*:*:*:*:*:*, p-cpe:2.3:a:amazon:linux:php54-intl:*:*:*:*:*:*:*, p-cpe:2.3:a:amazon:linux:php54-ldap:*:*:*:*:*:*:*, p-cpe:2.3:a:amazon:linux:php54-mbstring:*:*:*:*:*:*:*, p-cpe:2.3:a:amazon:linux:php54-mcrypt:*:*:*:*:*:*:*, p-cpe:2.3:a:amazon:linux:php54-mssql:*:*:*:*:*:*:*, p-cpe:2.3:a:amazon:linux:php54-mysql:*:*:*:*:*:*:*, p-cpe:2.3:a:amazon:linux:php54-mysqlnd:*:*:*:*:*:*:*, p-cpe:2.3:a:amazon:linux:php54-odbc:*:*:*:*:*:*:*, p-cpe:2.3:a:amazon:linux:php54-pdo:*:*:*:*:*:*:*, p-cpe:2.3:a:amazon:linux:php54-pgsql:*:*:*:*:*:*:*, p-cpe:2.3:a:amazon:linux:php54-process:*:*:*:*:*:*:*, p-cpe:2.3:a:amazon:linux:php54-pspell:*:*:*:*:*:*:*, p-cpe:2.3:a:amazon:linux:php54-recode:*:*:*:*:*:*:*, p-cpe:2.3:a:amazon:linux:php54-snmp:*:*:*:*:*:*:*, p-cpe:2.3:a:amazon:linux:php54-soap:*:*:*:*:*:*:*, p-cpe:2.3:a:amazon:linux:php54-tidy:*:*:*:*:*:*:*, p-cpe:2.3:a:amazon:linux:php54-xml:*:*:*:*:*:*:*, p-cpe:2.3:a:amazon:linux:php54-xmlrpc:*:*:*:*:*:*:*

必要な KB アイテム: Host/local_checks_enabled, Host/AmazonLinux/release, Host/AmazonLinux/rpm-list

パッチ公開日: 2015/7/7

参照情報

CVE: CVE-2015-4643, CVE-2015-4644, CVE-2015-3414, CVE-2015-3415, CVE-2015-4642, CVE-2014-3416

ALAS: 2015-561