Adobe Flash Player <= 18.0.0.194 の複数の脆弱性(APSB15-16)

critical Nessus プラグイン ID 84642
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモート Windows ホストには、複数の脆弱性による影響を受けるブラウザプラグインがインストールされています。

説明

リモート Windows ホストにインストールされている Adobe Flash Player のバージョンが、 18.0.0.194 より前です。したがって、以下の複数の脆弱性による影響を受けます:

- 攻撃者が Flash ヒープのアドレスを推測することを可能にする、情報漏洩の脆弱性が存在します。(CVE-2015-3097)

- 複数のヒープベースのバッファオーバーフローの脆弱性が存在し、任意のコードが実行される可能性があります。
(CVE-2015-3135、 CVE-2015-4432、CVE-2015-5118)

- 複数のメモリ破損の脆弱性が存在し、任意のコードが実行される可能性があります。(CVE-2015-3117、 CVE-2015-3123、CVE-2015-3130、CVE-2015-3133、 CVE-2015-3134、CVE-2015-4431)

- 複数の NULL ポインターデリファレンスの欠陥が存在します。
(CVE-2015-3126、 CVE-2015-4429)

- セキュリティバイパスの脆弱性が存在し、情報漏洩を引き起こす可能性があります。(CVE-2015-3114)

- 複数の型の取り違え(Type Confusion)の脆弱性が存在し、任意のコードが実行される可能性があります。(CVE-2015-3119、CVE-2015-3120、CVE-2015-3121、 CVE-2015-3122、CVE-2015-4433)

- 複数の use-after-free エラーが存在し、任意のコードが実行される可能性があります。- CVE-2015-3118、CVE-2015-3124、CVE-2015-5117、CVE-2015-3127、CVE-2015-3128、CVE-2015-3129、CVE-2015-3131、CVE-2015-3132、CVE-2015-3136、CVE-2015-3137、CVE-2015-4428、CVE-2015-4430、CVE-2015-5119:

- 複数の同一生成元ポリシーバイパスの脆弱性が存在し、情報漏洩を引き起こす可能性があります。(CVE-2014-0578、CVE-2015-3115、CVE-2015-3116、 CVE-2015-3125、CVE-2015-5116)

- ユーザー提供の入力の不適切な検証により、メモリ破損の問題が存在します。攻撃者がこれを悪用して、任意のコードを実行する可能性があります。(CVE-2015-5124)

ソリューション

Adobe Flash バージョン 18.0.0.203 または以降にアップグレードしてください。

または、18.x にアップグレードできないこれらのインストールに対して、 Adobe はバージョン 13.0.0.302 を用意しています。

関連情報

https://helpx.adobe.com/security/products/flash-player/apsb15-16.html

http://www.nessus.org/u?0cb17c10

プラグインの詳細

深刻度: Critical

ID: 84642

ファイル名: flash_player_apsb15-16.nasl

バージョン: 1.12

タイプ: local

エージェント: windows

ファミリー: Windows

公開日: 2015/7/9

更新日: 2019/11/22

依存関係: flash_player_installed.nasl

リスク情報

CVSS スコアのソース: CVE-2015-5124

VPR

リスクファクター: Critical

スコア: 9.8

CVSS v2

リスクファクター: Critical

Base Score: 10

Temporal Score: 8.7

ベクトル: AV:N/AC:L/Au:N/C:C/I:C/A:C

現状ベクトル: E:H/RL:OF/RC:C

脆弱性情報

CPE: cpe:/a:adobe:flash_player

必要な KB アイテム: SMB/Flash_Player/installed

エクスプロイトが利用可能: true

エクスプロイトの容易さ: Exploits are available

パッチ公開日: 2015/7/8

脆弱性公開日: 2015/7/8

エクスプロイト可能

CANVAS (CANVAS)

Core Impact

Metasploit (Adobe Flash Player ByteArray Use After Free)

参照情報

CVE: CVE-2014-0578, CVE-2015-3097, CVE-2015-3114, CVE-2015-3115, CVE-2015-3116, CVE-2015-3117, CVE-2015-3118, CVE-2015-3119, CVE-2015-3120, CVE-2015-3121, CVE-2015-3122, CVE-2015-3123, CVE-2015-3124, CVE-2015-3125, CVE-2015-3126, CVE-2015-3127, CVE-2015-3128, CVE-2015-3129, CVE-2015-3130, CVE-2015-3131, CVE-2015-3132, CVE-2015-3133, CVE-2015-3134, CVE-2015-3135, CVE-2015-3136, CVE-2015-3137, CVE-2015-4428, CVE-2015-4429, CVE-2015-4430, CVE-2015-4431, CVE-2015-4432, CVE-2015-4433, CVE-2015-5116, CVE-2015-5117, CVE-2015-5118, CVE-2015-5119, CVE-2015-5124

BID: 75090, 75568, 75590, 75591, 75592, 75593, 75594, 75595, 75596