Apache 2.4.x < 2.4.16の複数の脆弱性

medium Nessus プラグイン ID 84959

概要

リモートのWebサーバーは複数の脆弱性の影響を受けます。

説明

バナーによると、リモートホストにインストールされている Apache 2.4.x のバージョンは、2.4.16 より前です。したがって、次の脆弱性の影響を受けます。

- 「mod_lua」モジュールのlua_websocket_read()関数に、WebSocket PINGフレームの不適切な処理による欠陥が存在します。リモートの攻撃者が、これを悪用し、Lua scriptがwsupgrade()関数を呼び出した後に、細工されたWebSocket PINGフレームを送信することで、子プロセスをクラッシュさせるため、サービス拒否状態を引き起こす可能性があります。(CVE-2015-0228)

- プロトコル構造メンバーの初期化の失敗のため、read_request_line() 関数に NULL ポインターデリファレンスの欠陥が存在します。リモートの攻撃者が、この欠陥を悪用し、メソッドが欠落しているリクエストを送信することにより、INCLUDESフィルターが有効で、ローカルURIを指定するErrorDocument 400ディレクティブがあるインストールで、サービス拒否状態を引き起こす可能性があります。(CVE-2015-0253)

- チャンクヘッダーを適切に解析できないため、チャンク転送コーディングの実装に欠陥が存在します。リモートの攻撃者がこれを悪用して、 HTTP リクエストスマグリング攻撃を行うおそれがあります。(CVE-2015-3183)

- 要求ディレクティブが認証設定ではなく承認設定に関連している可能性を考慮していないため、ap_some_auth_required() 関数に欠陥が存在します。リモートの攻撃者が、これを悪用し、2.2 API の挙動を信頼するモジュールが存在すると、意図されているアクセス制限をバイパスする可能性があります。
(CVE-2015-3185)

- keystream の生成におけるダブルバイトの初期バイアスにより、RC4 アルゴリズムに欠陥が存在します。攻撃者はこれを悪用して、推測的な平文ディストリビューションを keystream ディストリビューション統計と組み合わせるベイズ解析を介して、暗号化テキストの平文回復を実行できます。注意:RC4 暗号化パッケージは RFC 7465 により禁止されています。この問題は Apache バージョン 2.4.13 で修正されましたが、2.4.13、2.4.14、および 2.4.15 は公にリリースされませんでした。

Nessusはこれらの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

Apacheをバージョン2.4.16以降にアップグレードしてください。あるいは、影響を受けるモジュールを絶対に使用しないでください。

関連情報

https://archive.apache.org/dist/httpd/CHANGES_2.4.16

http://httpd.apache.org/security/vulnerabilities_24.html

http://www.nessus.org/u?7ec9a07a

https://tools.ietf.org/html/rfc7465

プラグインの詳細

深刻度: Medium

ID: 84959

ファイル名: apache_2_4_16.nasl

バージョン: 1.18

タイプ: combined

エージェント: windows, macosx, unix

ファミリー: Web Servers

公開日: 2015/7/23

更新日: 2022/4/11

サポートされているセンサー: Nessus Agent

リスク情報

CVSS スコアのソース: CVE-2015-3183

VPR

リスクファクター: Medium

スコア: 4.4

CVSS v2

リスクファクター: Medium

Base Score: 5

Temporal Score: 3.7

ベクトル: AV:N/AC:L/Au:N/C:N/I:P/A:N

現状ベクトル: E:U/RL:OF/RC:C

CVSS v3

リスクファクター: Medium

Base Score: 5.3

Temporal Score: 4.6

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: cpe:/a:apache:http_server

必要な KB アイテム: installed_sw/Apache

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2015/7/15

脆弱性公開日: 2015/2/3

参照情報

CVE: CVE-2015-0228, CVE-2015-0253, CVE-2015-3183, CVE-2015-3185

BID: 73041, 75963, 75964, 75965