PHP 5.4.x < 5.4.45 の複数の脆弱性

high Nessus プラグイン ID 85885
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモート Web サーバーは、複数の脆弱性の影響を受ける PHP バージョンを使用しています。

説明

バナーによると、リモート Web サーバーで実行している PHP のバージョンは、5.4.45 より前の 5.4.x です。したがって、次の脆弱性の影響を受けます:

- unserialize() 関数に関連した、複数の use-after-free メモリエラーが存在します。リモートの攻撃者がこれらのエラーを悪用し、任意のコードを実行する可能性があります。
(CVE-2015-6834)

- php_var_unserialize() 関数に関連した、use-after-free メモリエラーが存在します。リモートの攻撃者が特別に細工されたシリアライズ文字列を使用することで、このエラーを悪用して任意のコードを実行する可能性があります。(CVE-2015-6835)

- ヘッダーフィールドの不適切な検証により、serialize_function_call() 関数に関連した、型の取り違え(Type Confusion)エラーが存在します。リモートの攻撃者がこれを悪用して詳細不明な影響を与える可能性があります。(CVE-2015-6836)

- libxslt ライブラリから入力の不適切な検証により、XSLTProcessor クラスに、複数の欠陥が存在します。リモートの攻撃者がこれらの欠陥を悪用して、詳細不明な影響を与える可能性があります。(CVE-2015-6837、 CVE-2015-6838)

- ユーザー提供の入力の不適切なサニタイズにより、php_zip.c ファイルの php_zip_extract_file() 関数に、欠陥が存在します。認証されていないリモートの攻撃者がこれを悪用して、制限されたパス外に任意のディレクトリを作成する可能性があります。(OSVDB 127122)

Nessus はこれらの問題に対してテストされていませんが、その代わりにアプリケーションの自己報告されたバージョン番号のみに依存していることに、注意してください。

ソリューション

PHP バージョン 5.4.45 または以降にアップグレードしてください。

関連情報

http://php.net/ChangeLog-5.php#5.4.45

プラグインの詳細

深刻度: High

ID: 85885

ファイル名: php_5_4_45.nasl

バージョン: 1.13

タイプ: remote

ファミリー: CGI abuses

公開日: 2015/9/10

更新日: 2021/1/19

依存関係: php_version.nasl

リスク情報

CVSS スコアのソース: CVE-2015-6836

VPR

リスクファクター: Medium

スコア: 6.7

CVSS v2

リスクファクター: High

Base Score: 7.5

Temporal Score: 5.9

ベクトル: AV:N/AC:L/Au:N/C:P/I:P/A:P

現状ベクトル: E:POC/RL:OF/RC:C

CVSS v3

リスクファクター: High

Base Score: 7.3

Temporal Score: 6.6

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

現状ベクトル: E:P/RL:O/RC:C

脆弱性情報

CPE: cpe:/a:php:php

必要な KB アイテム: www/PHP

エクスプロイトが利用可能: true

エクスプロイトの容易さ: No exploit is required

パッチ公開日: 2015/9/3

脆弱性公開日: 2014/9/10

参照情報

CVE: CVE-2014-9767, CVE-2015-6834, CVE-2015-6835, CVE-2015-6836, CVE-2015-6837, CVE-2015-6838

BID: 76644, 76649, 76652, 76733, 76734, 76738