Mac OS X:OS X Server < 5.0.3 複数の脆弱性

critical Nessus プラグイン ID 86066
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモートホストに、OS X Server 用のセキュリティ更新がありません。

説明

リモートの Mac OS X ホストには、 5.0.3 より前のバージョンの OS X Server がインストールされています。したがって、次の脆弱性の影響を受けます:

- mod_headers モジュールに欠陥が存在し、後でリクエスト処理の際に HTTP トレイラーが HTTP ヘッダーを置き換えることが可能です。リモートの攻撃者は、これを悪用して、任意のヘッダーを注入することができます。これによって、一部のモジュールが不適切に機能することや、不適切に機能しているように見えることもあります。
(CVE-2013-5704)

- データベースクラスターをテストで使用するための認証要件を特定する際に「make check」コマンドが initdb を適切に呼び出さないために、権限昇格の脆弱性が存在します。ローカルの攻撃者が、この問題を悪用して、サーバーに一時的にアクセスしたり、権限を昇格したりする可能性があります。(CVE-2014-0067)

- mod_cache モジュールに NULL ポインターデリファレンスの欠陥が存在します。リモートの攻撃者は、空の HTTP Content-Type ヘッダーを使ってこの脆弱性を悪用して、キャッシュフォワードプロキシ構成をクラッシュし、スレッド化された MPM を使用する場合にサービス拒否を引き起こせます。
(CVE-2014-3581)

- mod_proxy_fcgi モジュールに領域外メモリ読み取りの欠陥が存在します。攻撃者は、リモート FastCGI サーバーを使用して長いレスポンスヘッダーを送信し、この脆弱性を悪用して、バッファオーバーリードを引き起こしてサービス拒否を発生できます。(CVE-2014-3583)

- 複数の Require ディレクティブでさまざまな引数で使用される LuaAuthzProvider を処理するときに、モジュール od_lua に欠陥があります。攻撃者はこの脆弱性を悪用して、意図されているアクセス制限をバイパスできます。
(CVE-2014-8109)

- 制約違反のエラーメッセージで、制限された列の値を不適切に処理しているため、情報漏洩の脆弱性が存在します。認証されたリモートの攻撃者がこれを悪用して、機密情報へのアクセス権を取得する可能性があります。(CVE-2014-8161)

- Domain Name Service 内に、委任に従うために使用されるコードのエラーによる欠陥が存在します。リモートの攻撃者が、悪意をもって構成されたゾーンまたはクエリで、サービスにクエリを無制限に発行させ、リソースを使い果たさせる可能性があります。(CVE-2014-8500)

- 「mod_lua」モジュールの lua_websocket_read() 関数に、WebSocket PING フレームの不適切な処理による欠陥が存在します。リモートの攻撃者が、これを悪用し、 Lua script が wsupgrade() 関数を呼び出した後に、細工された WebSocket PING フレームを送信することで、子プロセスをクラッシュさせるため、サービス拒否状態を引き起こす可能性があります。(CVE-2015-0228)

- 「to_char」関数に関連する、バッファオーバーフローのエラーがいくつか存在するため、複数の脆弱性が存在します。認証されたリモートの攻撃者が、これらの問題を悪用して、サービス拒否や任意のコードの実行を引き起こす可能性があります。(CVE-2015-0241)

- さまざまな *printf() 関数にスタックベースのバッファオーバーフローのエラーがいくつか存在するため、複数の脆弱性が存在します。このオーバーフローは、浮動小数点数を書式設定する際に、リクエストされた精度が約 500 以上の場合に、ユーザー指定の入力を適切に検証していないため発生しています。認証されたリモートの攻撃者が、これらの問題を悪用して、サービス拒否や任意のコードの実行を引き起こす可能性があります。(CVE-2015-0242)

- 「pgcrypto」拡張での複数の関数にオーバーフローの状態があるため、複数の脆弱性が存在します。このオーバーフローは、メモリサイズを追跡する際に、ユーザー指定の入力を適切に検証していないため発生しています。認証されたリモートの攻撃者が、これらの問題を悪用して、サービス拒否や任意のコードの実行を引き起こす可能性があります。(CVE-2015-0243)

- コマンドパラメーター内の細工されたバイナリデータを処理する際に、ユーザー指定の入力を適切にサニタイズしていないため、SQL インジェクションの脆弱性が存在します。認証されたリモートの攻撃者が、この問題を悪用して、SQL クエリを注入したり操作したりすることができるため、任意のデータの操作または漏洩が引き起こされる可能性があります。
(CVE-2015-0244)

- プロトコル構造メンバーの初期化の失敗のため、read_request_line() 関数に NULL ポインターデリファレンスの欠陥が存在します。リモートの攻撃者が、この欠陥を悪用し、メソッドが欠落しているリクエストを送信することにより、 INCLUDES フィルターが有効で、ローカル URI を指定する ErrorDocument 400 ディレクティブがあるインストールで、サービス拒否状態を引き起こす可能性があります。(CVE-2015-0253)

- DNSSEC の検証と managed-keys の機能に関連するエラーがあるため、サービス拒否の脆弱性が存在します。リモートの攻撃者が、使える状態のキーがない状態になる間違ったトラストアンカー管理シナリオをトリガーする可能性があり、その結果、アサーションの失敗またはデーモンのクラッシュが引き起こされます。(CVE-2015-1349)

- PostgreSQL クライアントの切断タイムアウト失効に欠陥が存在し、セッション シャットダウン シーケンスの中でタイムアウト割り込みが部分的に発動されたときに発生します。(CVE-2015-3165)

- エラーチェックの失敗による欠陥が、print() 関数に存在しています。リモートの攻撃者が、これを利用して、機密情報にアクセスする可能性があります。(CVE-2015-3166)

PostgreSQL の pgcrypto コンポーネントに、間違ったキーでの復号化に関する複数のエラーメッセージがあります。リモートの攻撃者がこれを利用して、他のシステムから鍵を復元する可能性があります。(CVE-2015-3167)

- チャンクヘッダーを適切に解析できないため、チャンク転送コーディングの実装に欠陥が存在します。リモートの攻撃者がこれを悪用して、 HTTP リクエストスマグリング攻撃を行うおそれがあります。(CVE-2015-3183)

- 要求ディレクティブが認証設定ではなく承認設定に関連している可能性を考慮していないため、ap_some_auth_required() 関数に欠陥が存在します。リモートの攻撃者が、これを悪用し、2.2 API の挙動を信頼するモジュールが存在すると、意図されているアクセス制限をバイパスする可能性があります。
(CVE-2015-3185)

- 複数の詳細不明の XML の欠陥が Twisted に基づく Wiki Server に存在します。(CVE-2015-5911)

ソリューション

Mac OS X Server バージョン 5.0.3 以降にアップグレードしてください。

OS X Server 5.0.3 は、 OS X 10.10.5 またはそれ以降についてのみ利用可能です。

関連情報

https://support.apple.com/en-us/HT205219

http://www.nessus.org/u?b8a8a151

プラグインの詳細

深刻度: Critical

ID: 86066

ファイル名: macosx_server_5_0_3.nasl

バージョン: 1.9

タイプ: local

エージェント: macosx

公開日: 2015/9/22

更新日: 2019/11/22

依存関係: macosx_server_services.nasl

リスク情報

CVSS スコアのソース: CVE-2015-5911

VPR

リスクファクター: Medium

スコア: 5.9

CVSS v2

リスクファクター: Critical

Base Score: 10

Temporal Score: 7.4

ベクトル: AV:N/AC:L/Au:N/C:C/I:C/A:C

現状ベクトル: E:U/RL:OF/RC:C

脆弱性情報

CPE: cpe:/o:apple:mac_os_x_server

必要な KB アイテム: Host/local_checks_enabled, Host/MacOSX/Version, MacOSX/Server/Version

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2015/9/16

脆弱性公開日: 2015/9/16

参照情報

CVE: CVE-2013-5704, CVE-2014-0067, CVE-2014-3581, CVE-2014-3583, CVE-2014-8109, CVE-2014-8161, CVE-2014-8500, CVE-2015-0228, CVE-2015-0241, CVE-2015-0242, CVE-2015-0243, CVE-2015-0244, CVE-2015-0253, CVE-2015-1349, CVE-2015-3165, CVE-2015-3166, CVE-2015-3167, CVE-2015-3183, CVE-2015-3185, CVE-2015-5911

BID: 65721, 66550, 71590, 71656, 71657, 72538, 72540, 72542, 72543, 72673, 73040, 73041, 74787, 74789, 74790, 75963, 75964, 75965

APPLE-SA: APPLE-SA-2015-09-16-4