PHP 5.6.x < 5.6.14 の複数の脆弱性

high Nessus プラグイン ID 86301

概要

リモート Web サーバーは、複数の脆弱性の影響を受ける PHP バージョンを使用しています。

説明

バナーによると、リモート Web サーバーで実行している PHP のバージョンは、5.6.14 より前の 5.6.x です。したがって、以下の複数の脆弱性による影響を受けます:

- 存在しないファイルが指定される際に引き起こされる ext/phar/util.c の phar_get_fp_offset() 関数に、 NULL ポインターデリファレンスの欠陥が存在しています。認証されていないリモートの攻撃者がこれを悪用して、サービス拒否状態を引き起こす可能性があります。(OSVDB 128347)

- ext/phar/dirstream.c の phar_make_dirstream() 関数に、初期化されていないポインターの欠陥が存在します。これは、ファイル名が単一のフォーワードスラッシュ(/)である zip エントリファイル名を処理する際に発生します。認証されていないリモートの攻撃者はこれを悪用して、サービス拒否状態を起こすことや、機密情報を漏洩することがあります。
(OSVDB 128348)

Nessus はこれらの問題に対してテストされていませんが、その代わりにアプリケーションの自己報告されたバージョン番号のみに依存していることに、注意してください。

ソリューション

PHP バージョン 5.6.14 または以降にアップグレードしてください。

関連情報

http://php.net/ChangeLog-5.php#5.6.14

プラグインの詳細

深刻度: High

ID: 86301

ファイル名: php_5_6_14.nasl

バージョン: 1.14

タイプ: remote

ファミリー: CGI abuses

公開日: 2015/10/6

更新日: 2022/4/11

構成: 徹底的なチェックを有効にする

リスク情報

VPR

リスクファクター: High

スコア: 7.4

CVSS v2

リスクファクター: Medium

Base Score: 6.8

Temporal Score: 5

ベクトル: AV:N/AC:M/Au:N/C:P/I:P/A:P

現状ベクトル: E:U/RL:OF/RC:C

CVSS スコアのソース: CVE-2015-7803

CVSS v3

リスクファクター: High

Base Score: 8.6

Temporal Score: 7.5

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:H

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: cpe:/a:php:php

必要な KB アイテム: www/PHP

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2015/10/1

脆弱性公開日: 2015/5/28

参照情報

CVE: CVE-2015-7803, CVE-2015-7804

BID: 76959