SUSE SLED11 / SLES11 セキュリティ更新:wpa_supplicant(SUSE-SU-2015:2221-1)

medium Nessus プラグイン ID 87279
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモート SuSE ホストに1つ以上のセキュリティ更新がありません。

説明

2 つのセキュリティの問題を修正するために、wpa_supplicant が更新されました。

これらのセキュリティの問題が修正されました:

- CVE-2015-4142:hostapd および wpa_supplicant における、WMM Action フレームパーサーでの整数アンダーフローにより、AP モードの MLME/SME 機能性に使用された場合、リモートの攻撃者は、領域外の読み取りを誘発する細工されたフレームを通じて、サービス拒否(クラッシュ)を引き起こすことができました(bsc#930078)。

- CVE-2015-4141:WPS AP を使用している場合の hostapd での WPS UPnP 機能、および WPS 外部レジスタ(ER)を使用している場合の wpa_supplicant により、リモートの攻撃者は、領域外の読み取りまたはヒープベースのバッファオーバーフローを誘発する、負の長さのチャンクを通じて、サービス拒否(クラッシュ)を引き起こすことができました(bsc#930077)。

注意:Tenable Network Security は、前述の記述ブロックを SUSE セキュリティアドバイザリから直接抽出しています。Tenable では、できる限り新たな問題を持ち込まないように、自動的に整理して書式設定するようにしています。

ソリューション

この SUSE セキュリティ更新をインストールするには、YaST online_update を使用してください。
または、お使いの製品用に一覧になったコマンドを実行することも可能です。

SUSE Linux Enterprise Server for VMWare 11-SP3:

zypper in -t patch slessp3-wpa_supplicant-12252=1

SUSE Linux Enterprise Server 11-SP4:

zypper in -t patch slessp4-wpa_supplicant-12252=1

SUSE Linux Enterprise Server 11-SP3:

zypper in -t patch slessp3-wpa_supplicant-12252=1

SUSE Linux Enterprise Desktop 11-SP4:

zypper in -t patch sledsp4-wpa_supplicant-12252=1

SUSE Linux Enterprise Desktop 11-SP3:

zypper in -t patch sledsp3-wpa_supplicant-12252=1

お使いのシステムを最新の状態にするには、「zypper パッチ」を使用してください。

関連情報

https://bugzilla.suse.com/show_bug.cgi?id=930077

https://bugzilla.suse.com/show_bug.cgi?id=930078

https://www.suse.com/security/cve/CVE-2015-4141/

https://www.suse.com/security/cve/CVE-2015-4142/

http://www.nessus.org/u?dcb24f81

プラグインの詳細

深刻度: Medium

ID: 87279

ファイル名: suse_SU-2015-2221-1.nasl

バージョン: 2.8

タイプ: local

エージェント: unix

公開日: 2015/12/9

更新日: 2021/1/6

依存関係: ssh_get_info.nasl

リスク情報

VPR

リスクファクター: Low

スコア: 3.6

CVSS v2

リスクファクター: Medium

Base Score: 4.3

Temporal Score: 3.2

ベクトル: AV:N/AC:M/Au:N/C:N/I:N/A:P

現状ベクトル: E:U/RL:OF/RC:C

脆弱性情報

CPE: p-cpe:/a:novell:suse_linux:wpa_supplicant, p-cpe:/a:novell:suse_linux:wpa_supplicant-gui, cpe:/o:novell:suse_linux:11

必要な KB アイテム: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2015/12/7

脆弱性公開日: 2015/6/15

参照情報

CVE: CVE-2015-4141, CVE-2015-4142

BID: 74549