RHEL 7 : libpng (RHSA-2015:2596)

high Nessus プラグイン ID 87307
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモート Red Hat ホストに 1 つ以上のセキュリティ更新がありません。

説明

1 つのセキュリティ問題を修正する更新済み libpng パッケージが Red Hat Enterprise Linux 7 で現在利用可能です。

Red Hat 製品セキュリティは、この更新がセキュリティに及ぼす影響を重要度中として評価しています。詳細な重要度評価を示す Common Vulnerability Scoring System(CVSS)ベーススコアは「参照」セクションの CVE リンクで入手できます。

libpng パッケージには、ポータブル・ネットワーク・グラフィックス(PNG)の画像フォーマットファイルを作成し、操作するための関数のライブラリが収納されています。

Libpng の png_get_PLTE() および png_set_PLTE() 関数が、 8 以下のビット深度に対して最大パレットサイズを正しく計算していなかったことが分かりました。アプリケーションが適切に計算されたパレットサイズと共にこれらの関数を使用しようとした場合、バッファオーバーフローまたは領域外読み取りを引き起こす恐れがあります。攻撃者がこれを悪用し、何も知らないユーザーに特別に細工された PNG イメージの処理をさせることにより、クラッシュを引き起こしたり任意のコードを実行する恐れがあります。しかし、この影響はライブラリを使用するアプリケーションに依存しています。(CVE-2015-8126、 CVE-2015-8472)

libpng の全ユーザーは、バックポートされたパッチが含まれるこれらの更新済みパッケージへアップグレードし、この問題を修正することが推奨されます。

ソリューション

影響を受けるパッケージを更新してください。

関連情報

https://access.redhat.com/errata/RHSA-2015:2596

https://access.redhat.com/security/cve/cve-2015-8126

https://access.redhat.com/security/cve/cve-2015-8472

プラグインの詳細

深刻度: High

ID: 87307

ファイル名: redhat-RHSA-2015-2596.nasl

バージョン: 1.16

タイプ: local

エージェント: unix

公開日: 2015/12/10

更新日: 2019/10/24

依存関係: ssh_get_info.nasl

リスク情報

VPR

リスクファクター: Medium

スコア: 6

CVSS v2

リスクファクター: High

Base Score: 7.5

Temporal Score: 5.5

ベクトル: AV:N/AC:L/Au:N/C:P/I:P/A:P

現状ベクトル: E:U/RL:OF/RC:C

CVSS v3

リスクファクター: High

Base Score: 7.3

Temporal Score: 6.4

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: p-cpe:/a:redhat:enterprise_linux:libpng, p-cpe:/a:redhat:enterprise_linux:libpng-debuginfo, p-cpe:/a:redhat:enterprise_linux:libpng-devel, p-cpe:/a:redhat:enterprise_linux:libpng-static, cpe:/o:redhat:enterprise_linux:7, cpe:/o:redhat:enterprise_linux:7.2, cpe:/o:redhat:enterprise_linux:7.3, cpe:/o:redhat:enterprise_linux:7.4, cpe:/o:redhat:enterprise_linux:7.5, cpe:/o:redhat:enterprise_linux:7.6, cpe:/o:redhat:enterprise_linux:7.7

必要な KB アイテム: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list, Host/cpu

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2015/12/9

脆弱性公開日: 2015/11/12

参照情報

CVE: CVE-2015-8126, CVE-2015-8472

RHSA: 2015:2596