PHP 7.0.x < 7.0.3 の複数の脆弱性

critical Nessus プラグイン ID 88695
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモート Web サーバーは、複数の脆弱性の影響を受ける PHP バージョンを使用しています。

説明

バナーによると、リモート Web サーバーで実行している PHP のバージョンは、7.0.3 より前の 7.0.x です。したがって、以下の複数の脆弱性による影響を受けます:

- Perl-Compatible Regular Expressions(PCRE)ライブラリは、正規表現、サブルーチン呼び出し、バイナリファイルの処理に関連する複数の脆弱性の影響を受けます。リモートの攻撃者がこれらを悪用して、サービス拒否を引き起こしたり、機密情報を取得したり、詳細不明なその他の影響を及ぼしたりする可能性があります。(CVE-2015-8383、CVE-2015-8386、CVE-2015-8387、CVE-2015-8389、CVE-2015-8390、CVE-2015-8391、CVE-2015-8393、CVE-2015-8394)

- 文字列におけるプログラム切り捨て NULL バイトにより、escapeshellcmd() および escapeshellarg() 関数の ext/standard/exec.c ファイルに欠陥が存在します。リモートの攻撃者がこれを悪用して、制限をバイパスする可能性があります。
(VulnDB 134028)

- 設定されていないフィールドへのユーザー指定データの書き込みを制限できないことにより、stream_get_meta_data() 関数の ext/standard/streamsfuncs.c ファイルに欠陥が存在します。リモートの攻撃者がこれを悪用して、関数の出力を偽造し、悪意のあるメタデータの挿入を引き起こす可能性があります。(VulnDB 134029)

- WDDX パケットを逆シリアル化する際に、php_wddx_pop_element() 関数の ext/wddx/wddx.c ファイルに型の取り違え(Type Confusion)エラーが存在します。リモートの攻撃者はこれを悪用して詳細不明な影響を与える可能性があります。(VulnDB 134030)

- ユーザー指定入力の不適切な検証を引き起こす、初期化されていないメモリの使用により、PharFileInfo::getContent() メソッドの ext/phar/phar_object.c ファイルに欠陥が存在します。リモートの攻撃者はこれを悪用してメモリを破損できます。これにより、サービス拒否や任意のコード実行が発生します。(VulnDB 134031)

- 細工された TAR ファイルからのメタデータを解析する際に、phar_tar_setupmetadata() 関数の ext/phar/tar.c ファイルに NULL ポインターデリファレンスの欠陥が存在します。リモートの攻撃者が、これを悪用することにより、サービス拒否を引き起こす可能性があります。
(VulnDB 134032)

- ユーザー指定入力の不適切な検証により、iptcembed() 関数の ext/standard/iptc.c ファイルに整数オーバーフロー状態が存在します。リモートの攻撃者がこれを悪用して、ヒープベースのバッファオーバーフローを発生させ、サービス拒否または任意のコードの実行を引き起こす可能性があります。(VulnDB 134033)

- TAR ファイルを展開する際のユーザー指定入力の不適切な検証により、phar_parse_tarfile() 関数の ext/phar/tar.c ファイルにオーバーフロー状態が存在します。リモートの攻撃者がこれを悪用して、スタックベースのバッファオーバーフローを発生させ、サービス拒否または任意のコードの実行を引き起こす可能性があります。
(VulnDB 134034)

Nessus はこれらの問題に対してテストされていませんが、その代わりにアプリケーションの自己報告されたバージョン番号のみに依存していることに、注意してください。

ソリューション

PHP バージョン 7.0.3 または以降にアップグレードしてください。

関連情報

http://php.net/ChangeLog-7.php#7.0.3

プラグインの詳細

深刻度: Critical

ID: 88695

ファイル名: php_7_0_3.nasl

バージョン: 1.12

タイプ: remote

ファミリー: CGI abuses

公開日: 2016/2/11

更新日: 2019/3/27

依存関係: php_version.nasl

リスク情報

CVSS スコアのソース: CVE-2016-2554

VPR

リスクファクター: Medium

スコア: 5.9

CVSS v2

リスクファクター: Critical

Base Score: 10

Temporal Score: 7.4

ベクトル: AV:N/AC:L/Au:N/C:C/I:C/A:C

現状ベクトル: E:U/RL:OF/RC:C

CVSS v3

リスクファクター: Critical

Base Score: 9.8

Temporal Score: 8.5

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: cpe:/a:php:php

必要な KB アイテム: www/PHP

エクスプロイトの容易さ: No exploit is required

パッチ公開日: 2016/2/4

脆弱性公開日: 2015/11/23

参照情報

CVE: CVE-2015-8383, CVE-2015-8386, CVE-2015-8387, CVE-2015-8389, CVE-2015-8390, CVE-2015-8391, CVE-2015-8393, CVE-2015-8394, CVE-2016-2554, CVE-2016-4342, CVE-2016-4343

BID: 79810, 82990, 89179