Squid 3.x < 3.5.15 / 4.x < 4.0.7 の複数の DoS

high Nessus プラグイン ID 89080
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモートプロキシサーバーが、複数のサービス拒否の脆弱性の影響を受ける可能性があります。

説明

バナーによると、リモートホストで実行している Squid のバージョンは、3.5.15 以前の 3.x または 4.0.7 以前の 4.x です。このため、複数のサービス拒否脆弱性の影響を受ける可能性があります:

- String オブジェクトにデータを正しく追加しないために、欠陥が存在します。リモートの攻撃者がこれを悪用して、細工された HTTP Vary ヘッダーを通じて、アサーションエラーを引き起こすことや、デーモンを終了させることができ、サービス拒否状態を引き起こす可能性があります。(CVE-2016-2569)

- XML 解析中にバッファ制限をチェックしないために、Edge Side Includes(ESI)パーサーに欠陥が存在します。
リモートの攻撃者がこれを悪用して、細工された XML ドキュメントを通じて、アサーションエラーを引き起こすことや、デーモンを終了させることができ、サービス拒否状態を引き起こす可能性があります。(CVE-2016-2570)

- http.cc に欠陥が存在し、応答解析が失敗したあとでも、特定のデータ保存が許されます。リモートの攻撃者がこれを悪用して、無効な形式のサーバー応答を通じて、アサーションエラーを引き起こすことや、デーモンを終了させることができ、サービス拒否状態を引き起こす可能性があります。
CVE-2016-2571)

- 応答解析が失敗したあとでも、HTTP ステータスコードに依存するために、http.cc に欠陥が存在します。リモートの攻撃者がこれを悪用して、無効な形式のサーバー応答を通じて、アサーションエラーを引き起こすことや、デーモンを終了させることができ、サービス拒否状態を引き起こす可能性があります。
(CVE-2016-2572)

Nessus はこれらの問題に対してテストされていませんが、その代わりにアプリケーションの自己報告されたバージョン番号のみに依存していることに、注意してください。
さらに、これらの問題に対処するためにリリースされたパッチでは、バナーのバージョンは更新されません。このパッチが適切に適用され、サービスが再起動された場合には、これが偽陽性であると見なしてください。

ソリューション

Squid を 3.5.15 / 4.0.7 またはこれ以降のバージョンにアップグレードしてください。または、ベンダーから提供されたパッチを適用してください。

関連情報

http://www.squid-cache.org/Advisories/

http://www.squid-cache.org/Advisories/SQUID-2016_2.txt

プラグインの詳細

深刻度: High

ID: 89080

ファイル名: squid_4_0_7.nasl

バージョン: 1.5

タイプ: remote

ファミリー: Firewalls

公開日: 2016/3/2

更新日: 2019/11/20

依存関係: squid_version.nasl

構成: パラノイドモードの有効化

リスク情報

CVSS スコアのソース: CVE-2016-2572

VPR

リスクファクター: Low

スコア: 3.6

CVSS v2

リスクファクター: Medium

Base Score: 5

Temporal Score: 3.7

ベクトル: AV:N/AC:L/Au:N/C:N/I:N/A:P

現状ベクトル: E:U/RL:OF/RC:C

CVSS v3

リスクファクター: High

Base Score: 7.5

Temporal Score: 6.5

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: cpe:/a:squid-cache:squid

必要な KB アイテム: www/squid, Settings/ParanoidReport

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2016/2/23

脆弱性公開日: 2016/2/23

参照情報

CVE: CVE-2016-2569, CVE-2016-2570, CVE-2016-2571, CVE-2016-2572