openSUSE セキュリティ更新:python-Pillow(openSUSE-2016-339)

medium Nessus プラグイン ID 89949

概要

リモート openSUSE ホストに、セキュリティ更新がありません。

説明

python-Pillow 用のこの更新は、次の問題を修正します:

- 3.1.1 からのバックポートセキュリティ修正(Pillow-overflows.patch):

- Resample.c における整数オーバーフローを修正しました。これにより、Python ヒープの書き込みが引き起こされます。

- PcdDecode.c におけるバッファオーバーフローを修正しました。これにより PhotoCD ファイルを開く際にセグメンテーション違反が発生します。CVE-2016-TBD

- FliDecode.c におけるバッファオーバーフローを修正しました。これにより FLI ファイルを開く際にセグメンテーション違反が発生します。CVE-2016-0775(boo#965582 の修正)

- TiffDecode.c におけるバッファオーバーフローを修正しました。これにより、特別に細工された無効な TIFF ファイルを開く際に、任意の量のメモリが上書きされます。
CVE-2016-0740(boo#965579 の修正)

ソリューション

影響を受ける python-Pillow パッケージを更新してください。

関連情報

https://bugzilla.opensuse.org/show_bug.cgi?id=965579

https://bugzilla.opensuse.org/show_bug.cgi?id=965582

プラグインの詳細

深刻度: Medium

ID: 89949

ファイル名: openSUSE-2016-339.nasl

バージョン: 2.5

タイプ: local

エージェント: unix

公開日: 2016/3/16

更新日: 2021/1/19

サポートされているセンサー: Nessus Agent

リスク情報

VPR

リスクファクター: Low

スコア: 3.6

CVSS v2

リスクファクター: Medium

Base Score: 4.3

ベクトル: AV:N/AC:M/Au:N/C:N/I:P/A:N

CVSS v3

リスクファクター: Medium

Base Score: 6.5

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N

脆弱性情報

CPE: p-cpe:/a:novell:opensuse:python-Pillow, p-cpe:/a:novell:opensuse:python-Pillow-debuginfo, p-cpe:/a:novell:opensuse:python-Pillow-debugsource, p-cpe:/a:novell:opensuse:python-Pillow-tk, p-cpe:/a:novell:opensuse:python-Pillow-tk-debuginfo, cpe:/o:novell:opensuse:13.2, cpe:/o:novell:opensuse:42.1

必要な KB アイテム: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

パッチ公開日: 2016/3/15

参照情報

CVE: CVE-2016-0740, CVE-2016-0775