PHP 5.6.x < 5.6.19 の複数の脆弱性

critical Nessus プラグイン ID 90008
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモート Web サーバーは、複数の脆弱性の影響を受ける PHP バージョンを使用しています。

説明

バナーによると、リモート Web サーバーで実行している PHP のバージョンは、5.6.19 より前の 5.6.x です。したがって、以下の複数の脆弱性による影響を受けます:

- XML データを処理する際に、php_wddx_pop_element() 関数の ext/wddx/wddx.c ファイルに use-after-free エラーが存在します。認証されていないリモートの攻撃者がこれを悪用して、細工された XML データを通じて、すでに解放されたメモリを逆参照することで任意のコードを実行する可能性があります。
(CVE-2016-3141)

- phar_parse_zipfile() 関数の ext/phar/zip.c ファイルに領域外読み取りエラーが存在するため、認証されていないリモートの攻撃者がサービス拒否を引き起こしたり、機密情報にアクセスしたりすることが可能です。(CVE-2016-3142)

- the xsl_ext_function_php() 関数の ext/xsl/xsltprocessor.c ファイルに NULL ポインターデリファレンスの欠陥が存在するため、認証されていないリモートの攻撃者がサービス拒否を引き起こすことが可能です。(VulnDB 135344)

- ビルトイン HTTP サーバーがファイルのリクエストを適切に制限しないことにより、sapi/cli/php_cli_server.c ファイルに欠陥が存在します。認証されていないリモートの攻撃者がこれを悪用して、任意のファイルにアクセスする可能性があります。(VulnDB 135345)

- 現在の作業ディレクトリでキャッシュされたキャッシュ済みディレクトリ名を更新する場合、Zend Opcache に use-after-free エラーが存在します。認証されていないリモートの攻撃者がこれを悪用して、すでに解放されたメモリを逆参照して、任意のコードを実行する可能性があります。(VulnDB 135346)

- Zip::ExtractTo() メソッドの ext/zip/php_zip.c ファイルに NULL ポインターデリファレンスの欠陥が存在するため、認証されていないリモートの攻撃者がサービス拒否を引き起こすことが可能です。(VulnDB 135347)

Nessus はこれらの問題に対してテストされていませんが、その代わりにアプリケーションの自己報告されたバージョン番号のみに依存していることに、注意してください。

ソリューション

PHP バージョン 5.6.19 または以降にアップグレードしてください。

関連情報

http://php.net/ChangeLog-5.php#5.6.19

プラグインの詳細

深刻度: Critical

ID: 90008

ファイル名: php_5_6_19.nasl

バージョン: 1.16

タイプ: remote

ファミリー: CGI abuses

公開日: 2016/3/17

更新日: 2019/11/20

依存関係: php_version.nasl

リスク情報

CVSS スコアのソース: CVE-2016-3141

VPR

リスクファクター: Medium

スコア: 5.9

CVSS v2

リスクファクター: High

Base Score: 7.5

Temporal Score: 5.5

ベクトル: AV:N/AC:L/Au:N/C:P/I:P/A:P

現状ベクトル: E:U/RL:OF/RC:C

CVSS v3

リスクファクター: Critical

Base Score: 9.8

Temporal Score: 8.5

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: cpe:/a:php:php

必要な KB アイテム: www/PHP

エクスプロイトの容易さ: No exploit is required

パッチ公開日: 2016/3/3

脆弱性公開日: 2016/2/9

参照情報

CVE: CVE-2016-3141, CVE-2016-3142

BID: 84271, 84306, 84307, 84348, 84349, 84350, 84351