PHP 7.0.x < 7.0.5 の複数の脆弱性

critical Nessus プラグイン ID 90362
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモート Web サーバー上の PHP のバージョンは、以下の複数の脆弱性の影響を受けます:

説明

バナーによると、リモート Web サーバーで実行している PHP のバージョンは、7.0.5 より前の 7.0.x です。したがって、以下の複数の脆弱性による影響を受けます:

- マジックファイルの検証が不適切なために、バッファオーバーライト状態が finfo_open() 関数に存在します。認証されていないリモートの攻撃者がこれを悪用して、細工されたファイルを介して、サービス拒否を引き起こしたり、任意のコードを実行したりする可能性があります。(VulnDB 122863)

- ファイル ext/snmp/snmp.c 内の php_snmp_error() 関数に欠陥が存在し、書式文字列指示子を処理する際に引き起こされます。認証されていないリモートの攻撃者がこれを悪用して、細工された SNMP オブジェクトを介して、サービス拒否を引き起こしたり、任意のコードを実行したりする可能性があります。(VulnDB 136483)

- phar ファイル名を処理する際に、無効なメモリ読み取りエラーが存在し、攻撃者が詳細不明な影響を及ぼすことが可能です。(VulnDB 136484)

- 負のパラメーター値を処理する際に、ファイル ext/mbstring/libmbfl/mbfl/mbfilter.c 内の mbfl_strcut() 関数に欠陥が存在します。認証されていないリモートの攻撃者が、この問題を悪用し、サービス拒否を引き起こす可能性があります。
(VulnDB 136485)

- ユーザー指定入力の検証が不適切なために、ファイル ext/standard/url.c 内の php_raw_url_encode() 関数に整数オーバーフロー状態が存在します。認証されていないリモートの攻撃者はこれを悪用して、詳細不明な影響を与える可能性があります。
(VulnDB 136486)

Nessus はこれらの問題に対してテストされていませんが、その代わりにアプリケーションの自己報告されたバージョン番号のみに依存していることに、注意してください。

ソリューション

PHP バージョン 7.0.5 または以降にアップグレードしてください。

関連情報

http://php.net/ChangeLog-7.php#7.0.5

プラグインの詳細

深刻度: Critical

ID: 90362

ファイル名: php_7_0_5.nasl

バージョン: 1.14

タイプ: remote

ファミリー: CGI abuses

公開日: 2016/4/6

更新日: 2019/11/20

依存関係: php_version.nasl

リスク情報

CVSS スコアのソース: CVE-2016-4073

VPR

リスクファクター: Medium

スコア: 6.7

CVSS v2

リスクファクター: High

Base Score: 7.5

Temporal Score: 5.9

ベクトル: AV:N/AC:L/Au:N/C:P/I:P/A:P

現状ベクトル: E:POC/RL:OF/RC:C

CVSS v3

リスクファクター: Critical

Base Score: 9.8

Temporal Score: 8.8

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

現状ベクトル: E:P/RL:O/RC:C

脆弱性情報

CPE: cpe:/a:php:php

必要な KB アイテム: www/PHP

エクスプロイトが利用可能: true

エクスプロイトの容易さ: No exploit is required

パッチ公開日: 2016/3/31

脆弱性公開日: 2015/6/3

参照情報

CVE: CVE-2015-8865, CVE-2016-4070, CVE-2016-4071, CVE-2016-4072, CVE-2016-4073

EDB-ID: 39645, 39653