Scientific Linux セキュリティ更新:SL6.x i386/x86_64 の nss、nss-util、および nspr

high Nessus プラグイン ID 90392
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモート Scientific Linux ホストに 1 つ以上のセキュリティ更新がありません。

説明

次のパッケージが新しい Upstream バージョンにアップグレードされました:
nss 3.21.0、nss-util 3.21.0、nspr 4.11.0。

セキュリティ修正:

- NSS が DHE(ディフィー・ヘルマン鍵交換)および ECDHE(楕円曲線ディフィー・ヘルマン鍵交換)のハンドシェイクメッセージを処理する方法に、use-after-free の欠陥が見つかりました。リモートの攻撃者が、NSS に対してリンクされたアプリケーションによって解析されたときに、そのアプリケーションをクラッシュさせたり、特定の特別な条件下で、アプリケーションを実行しているユーザーの権限を使用して任意のコードを実行する、特別に細工されたハンドシェイクメッセージを送信する可能性があります。(CVE-2016-1978)

- NSS が特定の DER(Distinguished Encoding Rules)でエンコードされた暗号鍵を処理する方法で、use-after-free の欠陥が見つかりました。攻撃者がこの欠陥を利用して、特別に細工された DER でエンコードされた証明書を作成し、その証明書が NSS ライブラリでコンパイルされたアプリケーションで解析されるときに、アプリケーションをクラッシュさせたり、アプリケーションを実行しているユーザーの権限を使用して任意のコードを実行する可能性があります。(CVE-2016-1979)

ソリューション

影響を受けるパッケージを更新してください。

関連情報

http://www.nessus.org/u?51dc8bec

プラグインの詳細

深刻度: High

ID: 90392

ファイル名: sl_20160405_nss__nss_util__and_nspr_on_SL6_x.nasl

バージョン: 2.6

タイプ: local

エージェント: unix

公開日: 2016/4/7

更新日: 2021/1/14

依存関係: ssh_get_info.nasl

リスク情報

VPR

リスクファクター: Medium

スコア: 5.9

CVSS v2

リスクファクター: High

Base Score: 7.5

ベクトル: AV:N/AC:L/Au:N/C:P/I:P/A:P

CVSS v3

リスクファクター: High

Base Score: 8.8

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

脆弱性情報

CPE: p-cpe:/a:fermilab:scientific_linux:nspr, p-cpe:/a:fermilab:scientific_linux:nspr-debuginfo, p-cpe:/a:fermilab:scientific_linux:nspr-devel, p-cpe:/a:fermilab:scientific_linux:nss, p-cpe:/a:fermilab:scientific_linux:nss-debuginfo, p-cpe:/a:fermilab:scientific_linux:nss-devel, p-cpe:/a:fermilab:scientific_linux:nss-pkcs11-devel, p-cpe:/a:fermilab:scientific_linux:nss-sysinit, p-cpe:/a:fermilab:scientific_linux:nss-tools, p-cpe:/a:fermilab:scientific_linux:nss-util, p-cpe:/a:fermilab:scientific_linux:nss-util-debuginfo, p-cpe:/a:fermilab:scientific_linux:nss-util-devel, x-cpe:/o:fermilab:scientific_linux

必要な KB アイテム: Host/local_checks_enabled, Host/cpu, Host/RedHat/release, Host/RedHat/rpm-list

パッチ公開日: 2016/4/5

脆弱性公開日: 2016/3/13

参照情報

CVE: CVE-2016-1978, CVE-2016-1979