Piwik < 2.16.0 の特定されない XSS

medium Nessus プラグイン ID 90537

概要

リモート Web サーバーでホストされている Web アプリケーションは、クロスサイトスクリプティングの脆弱性の影響を受けます。

説明

リモートホストで実行されている Piwik は 2.16.0 より前のバージョンです。
このため、ユーザーに返す前に入力を適切に検証しないため、特定されないクロスサイトスクリプティング(XSS)の脆弱性の影響を受けます。認証されていないリモートの攻撃者が、細工されたリクエストを介してこれを悪用し、ユーザーのブラウザセッションで任意のスクリプトコードを実行する可能性があります。

ソリューション

Piwik をバージョン 2.16.0 以降にアップグレードしてください。必要に応じて、影響を受けるバージョンを削除してください。

関連情報

http://piwik.org/changelog/piwik-2-16-0/

プラグインの詳細

深刻度: Medium

ID: 90537

ファイル名: piwik_2_16_0.nasl

バージョン: 1.5

タイプ: remote

ファミリー: CGI abuses : XSS

公開日: 2016/4/15

更新日: 2022/4/11

構成: 徹底的なチェックを有効にする

リスク情報

CVSS v2

リスクファクター: Medium

Base Score: 4.3

Temporal Score: 3.7

ベクトル: AV:N/AC:M/Au:N/C:N/I:P/A:N

現状ベクトル: E:H/RL:OF/RC:C

脆弱性情報

CPE: cpe:/a:piwik:piwik

必要な KB アイテム: installed_sw/Piwik, www/PHP

パッチ公開日: 2016/2/4

脆弱性公開日: 2016/2/4