Scientific Linux セキュリティ更新:java-1.8.0-openjdk on SL7.x x86_64

critical Nessus プラグイン ID 90618
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモート Scientific Linux ホストに 1 つ以上のセキュリティ更新がありません。

説明

セキュリティ修正:

- OpenJDK でのシリアル化コンポーネントとホットスポットコンポーネントで、複数の欠陥が発見されました。信頼できない Java アプリケーションまたはアプレットがこれらの欠陥を利用して、Java サンドボックスの制限を完全にバイパスする可能性があります。
(CVE-2016-0686、CVE-2016-0687)

- OpenJDK での JMX コンポーネント内の RMI サーバーの実装では、認証証明書を逆シリアル化する際に、逆シリアル化される可能性があるクラスを制限していないことが判明しました。JMX ポートに接続できる認証されていないリモートの攻撃者は、この欠陥を利用して、逆シリアル化の欠陥を誘発する可能性があります。
(CVE-2016-3427)

- OpenJDK での JAXP コンポーネントは、XML 属性値の一部として、Unicode のサロゲートペアを適切に処理していないことが判明しました。特別に細工された XML の入力により、Java アプリケーションは、解析時に過剰な量のメモリを使用する可能性があります。(CVE-2016-3425)

- OpenJDK の JCE コンポーネントの GCM(Galois/Counter Mode)実装が、GCM 認証タグの比較時に一定でない時間比較を使用することが判明しました。リモートの攻撃者がこの欠陥を利用して、認証タグの値を判断する可能性があります。(CVE-2016-3426)

- OpenJDK でのセキュリティコンポーネントは、DSA 署名を生成する際に、ダイジェストアルゴリズムの強さをチェックできていないことが判明しました。強さがキーよりも弱いダイジェストを使用することで、予想外に弱い署名が生成される可能性があります。
(CVE-2016-0695)

注:icedtea-web パッケージが提供する Web ブラウザプラグインをインストールしている場合、ユーザーが悪意ある Web サイトにアクセスすると、 Java アプレットにより引き起こされる問題がユーザインタラクションなしに悪用される可能性があります。

ソリューション

影響を受けるパッケージを更新してください。

関連情報

http://www.nessus.org/u?0ba423d1

プラグインの詳細

深刻度: Critical

ID: 90618

ファイル名: sl_20160420_java_1_8_0_openjdk_on_SL7_x.nasl

バージョン: 2.8

タイプ: local

エージェント: unix

公開日: 2016/4/21

更新日: 2021/1/14

依存関係: ssh_get_info.nasl

リスク情報

VPR

リスクファクター: Critical

スコア: 9.2

CVSS v2

リスクファクター: Critical

Base Score: 10

ベクトル: AV:N/AC:L/Au:N/C:C/I:C/A:C

CVSS v3

リスクファクター: Critical

Base Score: 9.6

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H

脆弱性情報

CPE: p-cpe:/a:fermilab:scientific_linux:java-1.8.0-openjdk, p-cpe:/a:fermilab:scientific_linux:java-1.8.0-openjdk-accessibility, p-cpe:/a:fermilab:scientific_linux:java-1.8.0-openjdk-accessibility-debug, p-cpe:/a:fermilab:scientific_linux:java-1.8.0-openjdk-debug, p-cpe:/a:fermilab:scientific_linux:java-1.8.0-openjdk-debuginfo, p-cpe:/a:fermilab:scientific_linux:java-1.8.0-openjdk-demo, p-cpe:/a:fermilab:scientific_linux:java-1.8.0-openjdk-demo-debug, p-cpe:/a:fermilab:scientific_linux:java-1.8.0-openjdk-devel, p-cpe:/a:fermilab:scientific_linux:java-1.8.0-openjdk-devel-debug, p-cpe:/a:fermilab:scientific_linux:java-1.8.0-openjdk-headless, p-cpe:/a:fermilab:scientific_linux:java-1.8.0-openjdk-headless-debug, p-cpe:/a:fermilab:scientific_linux:java-1.8.0-openjdk-javadoc, p-cpe:/a:fermilab:scientific_linux:java-1.8.0-openjdk-javadoc-debug, p-cpe:/a:fermilab:scientific_linux:java-1.8.0-openjdk-src, p-cpe:/a:fermilab:scientific_linux:java-1.8.0-openjdk-src-debug, x-cpe:/o:fermilab:scientific_linux

必要な KB アイテム: Host/local_checks_enabled, Host/cpu, Host/RedHat/release, Host/RedHat/rpm-list

パッチ公開日: 2016/4/20

脆弱性公開日: 2016/4/21

参照情報

CVE: CVE-2016-0686, CVE-2016-0687, CVE-2016-0695, CVE-2016-3425, CVE-2016-3426, CVE-2016-3427