PHP 5.5.x < 5.5.35 の複数の脆弱性

critical Nessus プラグイン ID 90920

概要

リモート Web サーバー上で実行している PHP のバージョンは、以下の複数の脆弱性の影響を受けます:

説明

バナーによると、リモート Web サーバーで実行している PHP のバージョンは、5.5.35 より前の 5.5.x です。したがって、以下の複数の脆弱性による影響を受けます:

- 圧縮された GD2 データを処理する際にユーザー指定入力を適切に検証していないため、gd_gd2.c ファイル内の GD Graphics ライブラリに符号エラーが存在します。
認証されていないリモートの攻撃者がこれを悪用して、ヒープベースのバッファオーバーフローを引き起こし、サービス拒否状態または任意のコードの実行を引き起こす可能性があります。(CVE-2016-3074)

- zif_grapheme_stripos() 関数の負のオフセットを処理する際に、ext/intl/grapheme/grapheme_string.c ファイル内に領域外読み取りエラーが存在します。
認証されていないリモートの攻撃者がこれを悪用して、サービス拒否状態を引き起こしたり、メモリコンテンツを漏洩したりする可能性があります。(VulnDB 137781)

- マイナスのスケールを処理する際に、ext/bcmath/bcmath.c ファイル内の php_str2num() 関数に領域外読み取りエラーが存在します。認証されていないリモートの攻撃者がこれを悪用して、サービス拒否状態を引き起こしたり、メモリコンテンツを漏洩したりする可能性があります。(VulnDB 137782)

- exif ヘッダーを処理する際に、ext/exif/exif.c ファイル内の exif_read_data() 関数に領域外読み取りエラーが存在します。認証されていないリモートの攻撃者がこれを悪用して、サービス拒否状態を引き起こしたり、メモリコンテンツを漏洩したりする可能性があります。
(VulnDB 137783)

- 特別に細工された XML コンテンツを処理する際に、ext/xml/xml.c ファイル内の xml_parse_into_struct() 関数に欠陥が存在します。認証されていないリモートの攻撃者がこれを悪用して、サービス拒否状態を引き起こす可能性があります。(VulnDB 137784)

Nessus はこれらの問題に対してテストされていませんが、その代わりにアプリケーションの自己報告されたバージョン番号のみに依存していることに、注意してください。

ソリューション

PHP バージョン 5.5.35 または以降にアップグレードしてください。

参考資料

http://php.net/ChangeLog-5.php#5.5.35

プラグインの詳細

深刻度: Critical

ID: 90920

ファイル名: php_5_5_35.nasl

バージョン: 1.16

タイプ: remote

ファミリー: CGI abuses

公開日: 2016/5/5

更新日: 2024/5/31

設定: 徹底したチェックを有効にする

サポートされているセンサー: Nessus

リスク情報

VPR

リスクファクター: Medium

スコア: 6.7

CVSS v2

リスクファクター: High

基本値: 7.5

現状値: 5.9

ベクトル: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

CVSS スコアのソース: CVE-2016-3074

CVSS v3

リスクファクター: Critical

基本値: 9.8

現状値: 8.8

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

現状ベクトル: CVSS:3.0/E:P/RL:O/RC:C

脆弱性情報

CPE: cpe:/a:php:php

必要な KB アイテム: www/PHP

除外される KB アイテム: Settings/disable_cgi_scanning

エクスプロイトが利用可能: true

エクスプロイトの容易さ: No exploit is required

パッチ公開日: 2016/4/28

脆弱性公開日: 2016/4/21

参照情報

CVE: CVE-2016-3074, CVE-2016-4537, CVE-2016-4538, CVE-2016-4539, CVE-2016-4540, CVE-2016-4541, CVE-2016-4542, CVE-2016-4543, CVE-2016-4544