RHEL 7:pcre(RHSA-2016:1025)

high Nessus プラグイン ID 91078
New! Vulnerability Priority Rating (VPR)

Tenable では、すべての脆弱性に対して動的な VPR が計算されます。VPR は脆弱性の情報を、脅威インテリジェンスや機械学習アルゴリズムと組み合わせて、攻撃時に最も悪用される可能性の高い脆弱性を予測します。詳細は、 「VPR とは何で、CVSS とはどう違うのか」を参照してください。

VPR スコア : 5.9

概要

リモート Red Hat ホストに 1 つ以上のセキュリティ更新がありません。

説明

pcre 用の更新が、Red Hat Enterprise Linux 7 で現在利用可能です。

Red Hat 製品セキュリティは、この更新がセキュリティに及ぼす影響を重要度高として評価しています。詳細な重要度評価を示す Common Vulnerability Scoring System(CVSS)ベーススコアは、「参照」セクションで CVE リンクから脆弱性ごとに入手できます。

PCRE は Perl 互換の正規表現ライブラリです。

セキュリティ修正:

* PCRE が無効な形式の正規表現を処理する方法に複数の欠陥が見つかりました。PCRE プロセスを使用するアプリケーションを特別に細工された正規表現にすることができる攻撃者が、これらの欠陥を利用して、アプリケーションのクラッシュまたは任意のコードの実行を引き起こす可能性があります。(CVE-2015-8385、CVE-2016-3191、CVE-2015-2328、CVE-2015-3217、CVE-2015-5073、CVE-2015-8388、CVE-2015-8391、CVE-2015-8386)

ソリューション

影響を受けるパッケージを更新してください。

関連情報

https://access.redhat.com/errata/RHSA-2016:1025

https://access.redhat.com/security/cve/cve-2015-2328

https://access.redhat.com/security/cve/cve-2015-3217

https://access.redhat.com/security/cve/cve-2015-5073

https://access.redhat.com/security/cve/cve-2015-8385

https://access.redhat.com/security/cve/cve-2015-8386

https://access.redhat.com/security/cve/cve-2015-8388

https://access.redhat.com/security/cve/cve-2015-8391

https://access.redhat.com/security/cve/cve-2016-3191

プラグインの詳細

深刻度: High

ID: 91078

ファイル名: redhat-RHSA-2016-1025.nasl

バージョン: 2.13

タイプ: local

エージェント: unix

公開日: 2016/5/12

更新日: 2019/10/24

依存関係: ssh_get_info.nasl

リスク情報

リスクファクター: High

VPR スコア: 5.9

CVSS v2.0

Base Score: 9

Temporal Score: 6.7

ベクトル: AV:N/AC:L/Au:N/C:P/I:P/A:C

現状ベクトル: E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 9.8

Temporal Score: 8.5

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

現状ベクトル: E:U/RL:O/RC:C

脆弱性の情報

CPE: p-cpe:/a:redhat:enterprise_linux:pcre, p-cpe:/a:redhat:enterprise_linux:pcre-debuginfo, p-cpe:/a:redhat:enterprise_linux:pcre-devel, p-cpe:/a:redhat:enterprise_linux:pcre-static, p-cpe:/a:redhat:enterprise_linux:pcre-tools, cpe:/o:redhat:enterprise_linux:7, cpe:/o:redhat:enterprise_linux:7.2, cpe:/o:redhat:enterprise_linux:7.3, cpe:/o:redhat:enterprise_linux:7.4, cpe:/o:redhat:enterprise_linux:7.5, cpe:/o:redhat:enterprise_linux:7.6, cpe:/o:redhat:enterprise_linux:7.7

必要な KB アイテム: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list, Host/cpu

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2016/5/11

脆弱性公開日: 2015/12/1

参照情報

CVE: CVE-2015-2328, CVE-2015-3217, CVE-2015-5073, CVE-2015-8385, CVE-2015-8386, CVE-2015-8388, CVE-2015-8391, CVE-2016-3191

RHSA: 2016:1025