MySQL 5.7.x < 5.7.13 複数の脆弱性

low Nessus プラグイン ID 91997
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモートデータベースサーバーは、複数の脆弱性の影響を受けます。

説明

リモートホストで実行している MySQL のバージョンは、 5.7.13 より前の 5.7.x です。したがって、以下の複数の脆弱性による影響を受けます:

- crypto/evp/encode.c ファイル内の EVP_EncodeUpdate() 関数にヒープバッファオーバーフロー状態が存在します。これは、大量の入力データを処理する際に引き起こされます。認証されていないリモートの攻撃者がこれを悪用して、サービス拒否状態を引き起こす可能性があります。(CVE-2016-2105)

- Optimizer サブコンポーネントに複数の詳細不明な欠陥が存在するため、認証されたリモートの攻撃者がサービス拒否状態を引き起こすことが可能です。これ以上の詳細情報はありません。(CVE-2016-3424、CVE-2016-3440、CVE-2016-3501、 CVE-2016-3518)

- Security: Encryption サブコンポーネントに詳細不明な欠陥が存在するため、認証されていないリモートの攻撃者が潜在的な機密情報を漏洩することが可能です。
これ以上の詳細情報はありません。(CVE-2016-3452)

- InnoDB サブコンポーネントに複数の詳細不明な欠陥が存在するため、認証されたリモートの攻撃者がサービス拒否状態を引き起こすことが可能です。これ以上の詳細情報はありません。(CVE-2016-3459、CVE-2016-5436)

- Parser サブコンポーネントに詳細不明な欠陥が存在するため、ローカルの攻撃者が昇格された権限を取得することが可能です。これ以上の詳細情報はありません。
(CVE-2016-3477)

- FTS サブコンポーネントに詳細不明な欠陥が存在するため、認証されたリモートの攻撃者がサービス拒否状態を引き起こすことが可能です。これ以上の詳細情報はありません。(CVE-2016-3486)

- Types サブコンポーネントに詳細不明な欠陥が存在するため、認証されたリモートの攻撃者がサービス拒否状態を引き起こすことが可能です。これ以上の詳細情報はありません。(CVE-2016-3521)

- InnoDB サブコンポーネントに詳細不明な欠陥が存在するため、認証されたリモートの攻撃者が整合性および機密性に影響を与えることが可能です。これ以上の詳細情報はありません。(CVE-2016-3588)

- Security:
Encryption サブコンポーネントに複数の詳細不明な欠陥が存在するため、認証されたリモートの攻撃者がサービス拒否状態を引き起こすことが可能です。
これ以上の詳細情報はありません。(CVE-2016-3614、CVE-2016-5442)

- DML サブコンポーネントに詳細不明な欠陥が存在するため、認証されたリモートの攻撃者がサービス拒否状態を引き起こすことが可能です。これ以上の詳細情報はありません。(CVE-2016-3615)

- Log サブコンポーネントに詳細不明な欠陥が存在するため、認証されたリモートの攻撃者がサービス拒否状態を引き起こすことが可能です。これ以上の詳細情報はありません。(CVE-2016-5437)

- Privileges サブコンポーネントに詳細不明な欠陥が存在するため、認証されたリモートの攻撃者がサービス拒否状態を引き起こすことが可能です。これ以上の詳細情報はありません。(CVE-2016-5439)

- RBR サブコンポーネントに詳細不明な欠陥が存在するため、認証されたリモートの攻撃者がサービス拒否状態を引き起こすことが可能です。これ以上の詳細情報はありません。(CVE-2016-5440)

- Replication サブコンポーネントに詳細不明な欠陥が存在するため、認証されたリモートの攻撃者がサービス拒否状態を引き起こすことが可能です。これ以上の詳細情報はありません。(CVE-2016-5441)

- Connection サブコンポーネントに詳細不明な欠陥が存在するため、ローカルの攻撃者がサービス拒否状態を引き起こすことが可能です。これ以上の詳細情報はありません。(CVE-2016-5443)

- Connection サブコンポーネントに詳細不明な欠陥が存在するため、認証されていないリモートの攻撃者が潜在的な機密情報を漏洩することが可能です。
これ以上の詳細情報はありません。(CVE-2016-5444)

- InnoDB に複数の欠陥が存在します。これは、特別に細工された「ALTER TABLE」操作を処理する際に引き起こされます。認証されたリモートの攻撃者がこれらの問題を悪用して、データベースをクラッシュさせ、サービス拒否状態を引き起こす可能性があります。(VulnDB 139551)

- ユーザー指定入力の不適切な検証により、複数のオーバーフロー状態が存在します。認証されたリモートの攻撃者がこれらの問題を悪用して、サービス拒否状態または任意のコードの実行を引き起こす可能性があります。(VulnDB 139552)

パーサー構造に NULL ポインターデリファレンスの欠陥が存在します。これは、ストアド プロシージャ名の検証中に引き起こされます。認証されたリモートの攻撃者がこれを悪用して、データベースをクラッシュさせ、サービス拒否状態を引き起こす可能性があります。
(VulnDB 139553)

- ユーザー指定入力の不適切な検証により、InnoDB memcached プラグインに複数のオーバーフロー状態が存在します。認証されたリモートの攻撃者がこれらの問題を悪用して、サービス拒否状態または任意のコードの実行を引き起こす可能性があります。
(VulnDB 139554)

- 複数のスレッドで、Enterprise Encryption 関数を作成およびドロップした後、または同時に当該関数を呼び出す際に引き起こされる、詳細不明な欠陥が存在します。認証されたリモートの攻撃者がこれを悪用して、データベースをクラッシュさせ、サービス拒否状態を引き起こす可能性があります。(VulnDB 139555)

- ルースインデックススキャンによって実行された「SELECT ...GROUP BY ...FOR UPDATE」クエリを処理する際に引き起こされる、詳細不明な欠陥が存在します。認証されたリモートの攻撃者がこれを悪用して、データベースをクラッシュさせ、サービス拒否状態を引き起こす可能性があります。
(VulnDB 139556)

- 破棄されたテーブルスペースを伴うテーブル上で「FLUSH TABLES」操作を実行する際に引き起こされる、詳細不明な欠陥が存在します。認証されたリモートの攻撃者がこれを悪用して、データベースをクラッシュさせ、サービス拒否状態を引き起こす可能性があります。(VulnDB 139558)

- InnoDB に欠陥が存在します。これは、フルテキストインデックスを伴うテーブル上で「OPTIMIZE TABLE」操作を実行する際に引き起こされます。認証されたリモートの攻撃者がこれを悪用して、データベースをクラッシュさせ、サービス拒否状態を引き起こす可能性があります。(VulnDB 139559)

- 生成された仮想 BLOB 列上で UPDATE 操作を実行する際に引き起こされる、詳細不明な欠陥が存在します。認証されたリモートの攻撃者がこれを悪用して、データベースをクラッシュさせ、サービス拒否状態を引き起こす可能性があります。(VulnDB 139560)

- 生成された列を伴うテーブル上で「SHOW CREATE TABLE」操作を実行する際に引き起こされる、詳細不明な欠陥が存在します。認証されたリモートの攻撃者がこれを悪用して、データベースをクラッシュさせ、サービス拒否状態を引き起こす可能性があります。
(VulnDB 139561)

Nessus はこれらの問題に対してテストされていませんが、その代わりにアプリケーションの自己報告されたバージョン番号のみに依存していることに、注意してください。

ソリューション

MySQL バージョン 5.7.13 以降にアップグレードしてください。

関連情報

http://www.nessus.org/u?453b5f8c

http://www.nessus.org/u?bac902d5

https://dev.mysql.com/doc/relnotes/mysql/5.7/en/news-5-7-13.html

プラグインの詳細

深刻度: Low

ID: 91997

ファイル名: mysql_5_7_13.nasl

バージョン: 1.16

タイプ: remote

ファミリー: Databases

公開日: 2016/7/20

更新日: 2019/11/14

依存関係: mysql_version.nasl, mysql_login.nasl

構成: パラノイドモードの有効化

リスク情報

CVSS スコアのソース: CVE-2016-8288

VPR

リスクファクター: Medium

スコア: 6.5

CVSS v2

リスクファクター: Medium

Base Score: 4.9

Temporal Score: 3.6

ベクトル: AV:N/AC:M/Au:S/C:N/I:P/A:P

現状ベクトル: E:U/RL:OF/RC:C

CVSS v3

リスクファクター: Low

Base Score: 3.1

Temporal Score: 2.7

ベクトル: CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:L/A:N

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: cpe:/a:oracle:mysql

必要な KB アイテム: Settings/ParanoidReport

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2016/7/18

脆弱性公開日: 2016/5/3

参照情報

CVE: CVE-2016-2105, CVE-2016-3424, CVE-2016-3440, CVE-2016-3452, CVE-2016-3459, CVE-2016-3477, CVE-2016-3486, CVE-2016-3501, CVE-2016-3518, CVE-2016-3521, CVE-2016-3588, CVE-2016-3614, CVE-2016-3615, CVE-2016-5436, CVE-2016-5437, CVE-2016-5439, CVE-2016-5440, CVE-2016-5441, CVE-2016-5442, CVE-2016-5443, CVE-2016-5444, CVE-2016-8288

BID: 89757, 91902, 91906, 91910, 91915, 91917, 91932, 91943, 91949, 91953, 91960, 91963, 91967, 91969, 91974, 91976, 91980, 91983, 91987, 91992, 91999, 93740