Splunk Enterprise < 5.0.16 / 6.0.12 / 6.1.11 / 6.2.11 / 6.3.6 / 6.4.2 または Splunk Light < 6.4.2 の複数の脆弱性

high Nessus プラグイン ID 92790

概要

リモート Web サーバーで実行されているアプリケーションは、複数の脆弱性の影響を受けます。

説明

自己報告されたバージョン番号によると、リモート Web サーバーでホストされている Splunk Enterprise のバージョンは、5.0.x、6.0.12 より前の 6.0.x、6.1.11 より前の 6.1.x、6.2.11 より前の 6.2.x、6.3.6 より前の 6.3.x、6.4.2 より前の 6.4.x、あるいは Splunk Light の 6.4.2 より前の 6.4.x のバージョンです。したがって、次の脆弱性の影響を受けます:

- 64 ビットの CPU で実行している場合、ファイル archive_write_set_format_zip.c 内の archive_write_zip_data() 関数の libarchive に、署名されていない整数タイプと署名された整数タイプの間の変換が不適切なことによる、整数符号のエラーが存在します。認証されていないリモートの攻撃者がこれを悪用して、バッファオーバーフローを発生させ、サービス拒否状態を引き起こす可能性があります。
(CVE-2013-0211)

- ファイル cpio/cpio.c 内の bsdcpio() 関数の libarchive に、ユーザー指定の入力のサニタイズが不適切なことによる、パストラバーサルの脆弱性が存在します。認証されていないリモートの攻撃者がこれを悪用して、アーカイブの特別に細工されたパスを介して、任意のファイルに書き込みを行う可能性があります。(CVE-2015-2304)

- ファイル archive_read_support_format_zip.c 内の zip_read_mac_metadata() 関数の libarchive に、ユーザー指定入力のサニタイズが不適切なことによる、ヒープベースのバッファオーバーフロー状態が存在します。認証されていないリモートの攻撃者がこれを悪用して、ZIP アーカイブの特別に細工されたエントリサイズ値を通じて、サービス拒否状態を引き起こしたり、任意のコードを実行したりする可能性があります。(CVE-2016-1541)

- crypto/evp/e_aes_cbc_hmac_sha1.c ファイル内の aesni_cbc_hmac_sha1_cipher() 関数 および crypto/evp/e_aes_cbc_hmac_sha256.c ファイル内の aesni_cbc_hmac_sha256_cipher() 関数の OpenSSL ライブラリに、接続が AES-CBC 暗号を使用し、AES-NI がサーバーによってサポートされている場合に引き起こされる複数の欠陥が存在します。中間者攻撃の攻撃者が、これらを悪用して、パディングオラクル攻撃を行い、ネットワークトラフィックを解読する機能を取得する可能性があります。
(CVE-2016-2107)

- ユーザー指定入力の検証が不適切であるため、詳細不明なクロスサイトスクリプティング(XSS)の脆弱性が存在します。認証されていないリモートの攻撃者がこれを悪用し、特別に細工されたリクエストを介して、ユーザーのブラウザセッションで任意のスクリプトコードを実行する可能性があります。
(VulnDB 142260)

- ユーザー指定入力の検証が不適切であるため、詳細不明なクロスサイトリダイレクトの脆弱性が存在します。認証されていないリモートの攻撃者がこれを悪用し、ユーザーを騙して、特別に細工された Web リンクにアクセスさせることで、攻撃者が選択する任意の Web サイトにブラウザをリダイレクトする可能性があります。(VulnDB 142261)

注意:Splunk Enterprise 5.0.x は OpenSSL の問題に対するパッチを受けていないため、最新バージョンにアップグレードすることが推奨されます。

Nessus はこれらの問題に対してテストされていませんが、その代わりにアプリケーションの自己報告されたバージョン番号のみに依存していることに、注意してください。

ソリューション

Splunk Enterprise をバージョン 6.0.12 / 6.1.11 / 6.2.11 / 6.3.6 / 6.4.2 以降にアップグレードし、Splunk Light をバージョン 6.4.2 以降にアップグレードしてください。

参考資料

https://www.splunk.com/view/SP-CAAAPQM

https://www.openssl.org/news/secadv/20160503.txt

プラグインの詳細

深刻度: High

ID: 92790

ファイル名: splunk_642.nasl

バージョン: 1.7

タイプ: remote

ファミリー: CGI abuses

公開日: 2016/8/8

更新日: 2019/11/14

サポートされているセンサー: Nessus

リスク情報

VPR

リスクファクター: Medium

スコア: 5.9

CVSS v2

リスクファクター: Medium

Base Score: 6.8

Temporal Score: 5.3

ベクトル: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

CVSS v3

リスクファクター: High

Base Score: 8.8

Temporal Score: 7.9

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

現状ベクトル: CVSS:3.0/E:P/RL:O/RC:C

脆弱性情報

CPE: cpe:/a:splunk:splunk, cpe:/a:openssl:openssl, cpe:/a:libarchive:libarchive

必要な KB アイテム: installed_sw/Splunk

エクスプロイトが利用可能: true

エクスプロイトの容易さ: No exploit is required

パッチ公開日: 2016/7/28

脆弱性公開日: 2013/3/22

参照情報

CVE: CVE-2013-0211, CVE-2015-2304, CVE-2016-1541, CVE-2016-2107

BID: 58926, 89355, 89760, 92183, 92184

CERT: 862384