PHP 5.6.x < 5.6.25 の複数の脆弱性

critical Nessus プラグイン ID 93077

概要

リモート Web サーバー上で実行している PHP のバージョンは、以下の複数の脆弱性の影響を受けます:

説明

バナーによると、リモート Web サーバーで実行している PHP のバージョンは、5.6.25 より前の 5.6.x です。したがって、以下の複数の脆弱性による影響を受けます:

- var_unserializer.c の object_common2() 関数に詳細不明な欠陥が存在し、逆シリアル化中にオブジェクトを処理する際に発生します。認証されていないリモート攻撃者が、この脆弱性を悪用して、任意のコードを実行する可能性があります。(VulnDB 143096)

- snmp.c の php_snmp_parse_oid() 関数に整数オーバーフロー状態が存在します。認証されていないリモートの攻撃者は、これを悪用して、ヒープベースのバッファオーバーフローを引き起こし、任意のコードを実行する可能性があります。(VulnDB 143100)

- 整数切り捨ての欠陥が gd_topal.c の select_colors() 関数に存在し、色の数を処理する際に引きこされます。認証されていないリモートの攻撃者がこれを悪用して、ヒープベースのバッファオーバーフローを引き起こし、任意のコードを実行する可能性があります。
(VulnDB 143101)

- 過剰に長い文字列の処理が不適切なために、ereg.c の sql_regcase() 関数にオーバーフローの状態が存在します。認証されていないリモートの攻撃者がこれを悪用し、メモリを破損させ、任意のコードを実行する可能性があります。(VulnDB 143102)

NULL ポインターデリファレンスの欠陥が wddx.c の php_wddx_pop_element() 関数に存在し、Base64 バイナリ値を処理する際に引き起こされます。
認証されていないリモートの攻撃者がこれを悪用して、サービス拒否状態を引き起こす可能性があります。(VulnDB 143103)

- 詳細不明な NULL ポインターデリファレンスの欠陥が wddx.c の php_wddx_pop_element() 関数に存在します。認証されていないリモートの攻撃者がこれを悪用して、サービス拒否状態を引き起こす可能性があります。(VulnDB 143104)

- 整数オーバーフロー状態が base64.c の php_base64_encode() 関数に存在し、過剰に長い文字列を処理する際に発生します。認証されていないリモート攻撃者が、この脆弱性を悪用して、任意のコードを実行する可能性があります。(VulnDB 143105)

- NULL ポインターデリファレンスの欠陥が wddx.c の php_wddx_deserialize_ex() 関数に存在し、無効な XML コンテンツを処理する際に発生します。認証されていないリモートの攻撃者がこれを悪用して、サービス拒否状態を引き起こす可能性があります。(VulnDB 143106)

- quot_print.c の php_quot_print_encode() 関数に整数オーバーフロー状態が存在し、過剰に長い文字列を処理する際に発生します。認証されていないリモートの攻撃者は、これを悪用して、ヒープベースのバッファオーバーフロー状態を引き起こし、任意のコードを実行する可能性があります。(VulnDB 143107)

- var.c の unserialize() 関数に use-after-free エラーが存在します。認証されていないリモートの攻撃者がこれを悪用し、すでに解放されたメモリを逆参照して、任意のコードを実行する可能性があります。
(VulnDB 143108)

- ftp_fopen_wrapper.c の php_ftp_fopen_connect() 関数に欠陥が存在し、セキュアな方式をリクエストしている場合でも、中間者攻撃者が通常の FTP に密かにダウングレードすることが可能です。(VulnDB 143109)

- wddx.c の php_wddx_process_data() 関数に欠陥が存在し、無効な dateTime 値を逆シリアル化する際に発生します。認証されていないリモートの攻撃者がこれを悪用して、サービス拒否状態を引き起こす可能性があります。
(VulnDB 143110)

- exif.c の exif_process_IFD_in_TIFF() 関数に欠陥が存在し、TIFF イメージコンテンツを処理する際に発生します。
認証されていないリモートの攻撃者がこれを悪用して、メモリコンテンツを漏洩させる可能性があります。(VulnDB 143111)

- url.c の php_url_encode() 関数に整数オーバーフロー状態が存在し、過剰に長い文字列を処理する際に発生します。認証されていないリモートの攻撃者がこれを悪用し、メモリを破損させ、任意のコードを実行する可能性があります。(VulnDB 143112)

- uuencode.c の php_uuencode() 関数に整数オーバーフロー状態が存在します。認証されていないリモートの攻撃者がこれを悪用し、メモリを破損させ、任意のコードを実行する可能性があります。(VulnDB 143113)

- bz2.c の bzdecompress() 関数に整数オーバーフロー状態が存在します。認証されていないリモートの攻撃者がこれを悪用し、メモリを破損させ、任意のコードを実行する可能性があります。
(VulnDB 143114)

- gd.c の imagegammacorrect() 関数にインデックスの欠陥が存在し、負のガンマ値を処理する際に発生します。認証されていないリモートの攻撃者がこれを悪用して、NULL を任意のメモリ位置に書き込み、サービス拒否状態や任意のコードの実行を引き起こす可能性があります。(VulnDB 143116)

- interface.c の curl_escape() 関数に整数オーバーフロー状態が存在し、過剰に長いエスケープ付き文字列を処理する際に発生します。認証されていないリモートの攻撃者がこれを悪用し、メモリを破損させ、任意のコードを実行する可能性があります。(VulnDB 143117)

- session.c に詳細不明な欠陥が存在し、セッション名を処理する際に発生します。認証されていないリモートの攻撃者がこれを悪用して、任意のデータをセッションに注入する可能性があります。(VulnDB 143118)

ソリューション

PHP バージョン 5.6.25 または以降にアップグレードしてください。

参考資料

http://php.net/ChangeLog-5.php#5.6.25

プラグインの詳細

深刻度: Critical

ID: 93077

ファイル名: php_5_6_25.nasl

バージョン: 1.11

タイプ: remote

ファミリー: CGI abuses

公開日: 2016/8/23

更新日: 2022/4/11

設定: 徹底したチェックを有効にする

サポートされているセンサー: Nessus

リスク情報

VPR

リスクファクター: Medium

スコア: 6.7

CVSS v2

リスクファクター: High

Base Score: 7.5

Temporal Score: 5.5

ベクトル: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

CVSS スコアのソース: CVE-2016-7124

CVSS v3

リスクファクター: Critical

Base Score: 9.8

Temporal Score: 8.5

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

現状ベクトル: CVSS:3.0/E:U/RL:O/RC:C

脆弱性情報

CPE: cpe:/a:php:php

必要な KB アイテム: www/PHP

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2016/8/18

脆弱性公開日: 2016/8/10

参照情報

CVE: CVE-2016-7124, CVE-2016-7125, CVE-2016-7126, CVE-2016-7127, CVE-2016-7128, CVE-2016-7129, CVE-2016-7130, CVE-2016-7131, CVE-2016-7132

BID: 92552, 92564, 92755, 92756, 92757, 92758, 92764, 92767, 92768