PHP 7.0.x < 7.0.10 の複数の脆弱性

critical Nessus プラグイン ID 93078
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモート Web サーバー上で実行している PHP のバージョンは、以下の複数の脆弱性の影響を受けます:

説明

バナーによると、リモート Web サーバーで実行している PHP のバージョンは、7.0.10 より前の 7.0.x です。したがって、以下の複数の脆弱性による影響を受けます:

- 過剰に長い文字列が不適切に処理されているため、interface.c の curl_escape() 関数にオーバーフローの状態が存在します。認証されていないリモートの攻撃者がこれを悪用して、ヒープベースのバッファオーバーフローを引き起こし、サービス拒否状態または任意のコードの実行を引き起こす可能性があります。(VulnDB 143095)

- ユーザー指定の入力の不適切な検証により、zend_alloc.c の zend_mm_realloc_heap() 関数に、整数オーバーフロー状態が存在します。認証されていないリモートの攻撃者がこれを悪用して、バッファオーバーフローを引き起こしてサービス拒否状態にしたり、任意のコードの実行を引き起こす可能性があります。
(VulnDB 143115)

ソリューション

PHP バージョン 7.0.10 または以降にアップグレードしてください。

関連情報

http://php.net/ChangeLog-7.php#7.0.10

プラグインの詳細

深刻度: Critical

ID: 93078

ファイル名: php_7_0_10.nasl

バージョン: 1.12

タイプ: remote

ファミリー: CGI abuses

公開日: 2016/8/23

更新日: 2020/4/27

依存関係: php_version.nasl

リスク情報

CVSS スコアのソース: CVE-2016-7134

VPR

リスクファクター: High

スコア: 7.4

CVSS v2

リスクファクター: High

Base Score: 7.5

Temporal Score: 5.5

ベクトル: AV:N/AC:L/Au:N/C:P/I:P/A:P

現状ベクトル: E:U/RL:OF/RC:C

CVSS v3

リスクファクター: Critical

Base Score: 9.8

Temporal Score: 8.5

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: cpe:/a:php:php

必要な KB アイテム: www/PHP

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2016/8/18

脆弱性公開日: 2016/8/3

参照情報

CVE: CVE-2016-7124, CVE-2016-7125, CVE-2016-7126, CVE-2016-7127, CVE-2016-7128, CVE-2016-7129, CVE-2016-7130, CVE-2016-7131, CVE-2016-7132, CVE-2016-7133, CVE-2016-7134

BID: 92552, 92564, 92755, 92756, 92757, 92758, 92764, 92765, 92766, 92767, 92768