Tenable SecurityCenter < 5.3.0の複数の脆弱性(TNS-2016-04)

medium Nessus プラグイン ID 93343
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモートホストにインストールされているTenable SecurityCenterアプリケーションは、複数の脆弱性の影響を受けます。

説明

リモートホストにインストールされているTenable SecurityCenterアプリケーションはバージョン5.3.0より前であるか、セキュリティパッチがありません。したがって、PHPにバンドルされているPerl-Compatible Regular Expressions(PCRE)ライブラリの複数の脆弱性の影響を受けます。- 繰り返される条件付きグループを処理する時に、ユーザー指定入力の不適切な検証により、PCREライブラリにオーバーフロー状態が存在します。攻撃者がこれを悪用して、特別に細工された正規表現を通じて、バッファオーバーフローを引き起こし、サービス拒否状態につながる可能性があります。(CVE-2015-8383)-「lookbehind」アサーション内の相互再帰を処理するときに、ユーザー指定入力の不適切な検証により、PCREライブラリにオーバーフロー状態が存在します。攻撃者がこれを悪用して、スタックベースのバッファオーバーフローを引き起こし、サービス拒否状態につながる可能性があります。(CVE-2015-8386)-サブルーチン呼び出しを処理するときに、ユーザー指定入力が不適切に検証されているため、PCREライブラリに整数オーバーフロー状態が存在します。攻撃者がこれを悪用して、特別に細工された正規表現を通じて、サービス拒否状態を引き起こす可能性があります。(CVE-2015-8387)-/(?:|a|){100}x/パターンまたはその他の関連パターンが不適切に処理されているため、PCREライブラリに欠陥があります。攻撃者がこれを悪用して、特別に細工された正規表現を通じて、無限再帰を引き起こし、サービス拒否状態につながる可能性があります。(CVE-2015-8389)-文字クラス内の部分文字列[:および\\が不適切に処理されているため、PCREライブラリに欠陥があります。攻撃者がこれを悪用して、特別に細工された正規表現を通じて、初期化されていないメモリ読み取りを引き起こし、サービス拒否状態につながる可能性があります。(CVE-2015-8390)-[:ネスティングが不適切に処理されているため、pcre_compile.cのpcre_compile()関数内のPCREライブラリに欠陥があります。攻撃者がこれを悪用して、特別に細工された正規表現を通じて、CPUリソースの過剰消費を引き起こし、サービス拒否状態につながる可能性があります。(CVE-2015-8391)-バイナリファイルの「-q」オプションが不適切に処理されているため、PCREライブラリに欠陥があります。攻撃者がこれを悪用して、特別に細工されたファイルを介して、秘密情報を漏えいさせる可能性があります。(CVE-2015-8393)-(?(<digits>)および(?(R<digits>)条件を処理するときに、ユーザー指定入力が不適切に検証されているため、PCRE ライブラリに整数オーバーフロー状態が存在します。攻撃者がこれを悪用して、特別に細工された正規表現を通じてサービス拒否状態を引き起こす可能性があります。(CVE-2015-8394)Nessusはこれらの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

SecurityCenter バージョン5.3.0以降にアップグレードしてください。または、パッチSC-201603.1-5.x-rh5-64.tgzまたはSC-201603.1-5.x-rh6-64.tgz を適用してください。

関連情報

https://www.tenable.com/security/tns-2016-04

https://secure.php.net/ChangeLog-5.php#5.6.18

プラグインの詳細

深刻度: Medium

ID: 93343

ファイル名: securitycenter_php_5_6_18.nasl

バージョン: 1.12

タイプ: combined

エージェント: unix

ファミリー: Misc.

公開日: 2016/9/6

更新日: 2020/10/9

依存関係: securitycenter_installed.nbin, securitycenter_detect.nbin

リスク情報

CVSS スコアのソース: manual

CVSS スコアの根本的理由: Score based on analysis of the vendor advisory.

VPR

リスクファクター: Medium

スコア: 5.9

CVSS v2

リスクファクター: Medium

Base Score: 4

Temporal Score: 3

ベクトル: AV:N/AC:L/Au:S/C:N/I:N/A:P

現状ベクトル: E:U/RL:OF/RC:C

CVSS v3

リスクファクター: Medium

Base Score: 4.3

Temporal Score: 3.8

ベクトル: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: cpe:/a:tenable:securitycenter

必要な KB アイテム: Host/SecurityCenter/Version, installed_sw/SecurityCenter, Host/SecurityCenter/support/php/version

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2016/3/8

脆弱性公開日: 2015/11/23

参照情報

CVE: CVE-2015-8383, CVE-2015-8386, CVE-2015-8387, CVE-2015-8389, CVE-2015-8390, CVE-2015-8391, CVE-2015-8393, CVE-2015-8394

BID: 79810, 82990