MySQL 5.7.x < 5.7.15の複数の脆弱性

critical Nessus プラグイン ID 93380
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモートのデータベースサーバーは、複数の脆弱性の影響を受けます。

説明

リモートホストで実行されているMySQLのバージョンは、5.7.15より前の5.7.xです。したがって、以下の複数の脆弱性の影響を受けます。- Optimizerサブコンポーネントに複数の詳細不明な欠陥があり、認証されたリモートの攻撃者がサービス拒否状態を引き起こす可能性があります。(CVE-2016-3492、CVE-2016-5632)- InnoDBサブコンポーネントに詳細不明な欠陥があり、認証されたリモートの攻撃者がサービス拒否状態を引き起こす可能性があります。(CVE-2016-5507)- MyISAMサブコンポーネントに詳細不明な欠陥があり、ローカルの攻撃者が昇格した権限を取得する可能性があります。(CVE-2016-5616)- Error Handlingサブコンポーネントに詳細不明な欠陥があり、ローカルの攻撃者が昇格した権限を取得する可能性があります。(CVE-2016-5617)- Packagingサブコンポーネントに詳細不明な欠陥があり、ローカルの攻撃者が昇格した権限を取得する可能性があります。(CVE-2016-5625)- GISサブコンポーネントに詳細不明な欠陥があり、認証されたリモートの攻撃者がサービス拒否状態を引き起こす可能性があります。(CVE-2016-5626)- Federatedサブコンポーネントに詳細不明な欠陥があり、認証されたリモートの攻撃者がサービス拒否状態引き起こす可能性があります。(CVE-2016-5629)- ファイルsql/sys_vars.cc内のcheck_log_path()関数に、my.cnf構成ファイルへの書き込み権限の不十分な制限による欠陥があり、現在のバージョンで使用されていないパスロケーションから構成ファイルをロードする可能性があります。認証されたリモートの攻撃者が、ログ機能を活用する特別に細工されたクエリを利用することでこの問題を悪用して、新しいファイルを作成したり、既存のファイルにカスタムコンテンツを付加する可能性があります。これにより、攻撃者が、特別に細工されたmysql_hookandroot_lib.soファイルを指す「malloc_lib=」ディレクティブを持つカスタム.cnfファイルを挿入することでroot権限を取得し、これによりMySQLに次回起動時に悪意のあるライブラリをロードさせる可能性があります。(CVE-2016-6662)- 詳細不明な欠陥があり、認証されたリモートの攻撃者が制限をバイパスし、FILE権限の要件なくカスタムコンテンツで/var/lib/mysql/my.cnfファイルを作成する可能性があります。(CVE-2016-6663)- Typesサブコンポーネントに詳細不明な欠陥があり、認証されたリモートの攻撃者がサービス拒否状態を引き起こす可能性があります。(CVE-2016-8283)- Security: Privilegesサブコンポーネントに詳細不明な欠陥があり、認証されたリモートの攻撃者が秘密情報を漏えいさせる可能性があります。(CVE-2016-8286)- REPAIR TABLEによる一時ファイルの使用に関連する欠陥があります。認証されているリモートの攻撃者がこの脆弱性を悪用して、昇格された権限を取得する可能性があります。- フルテキスト検索テーブルをドロップし、作成した操作を処理する際に、InnoDB に欠陥が存在します。認証されたリモートの攻撃者がこれを悪用し、アサーションを発生させたり、サービス拒否状態を引き起こしたりする可能性があります。- インデックス化したテーブルのドロップ中にフルテキスト補助テーブルにアクセスする際に、InnoDB に欠陥が存在します。認証されたリモートの攻撃者がこれを悪用し、アサーションを発生させたり、サービス拒否状態を引き起こしたりする可能性があります。- MEDIUMINT列で長い整数値を処理するとき、特定の入力が不適切に検証されているため、バッファオーバーフローの状態があります。認証されたリモートの攻撃者がこれを悪用し、サービス拒否状態を引き起こしたり、任意のコードを実行したりする可能性があります。- 拒否されたパスワードがエラーログに平文として書かれているため、validate_password プラグインに情報漏洩の脆弱性が存在します。ローカルの攻撃者がこれを悪用し、どのようなパスワードが選択され、受け入れられているかを簡単に推測できる可能性があります。- システムテーブルスペースのテーブルに適用される「ALTER TABLE ... ENCRYPTION='Y'、ALGORITHM=COPY」操作を処理する際に InnoDB に欠陥が存在します。認証されたリモートの攻撃者がこれを悪用し、アサーションを発生させたり、サービス拒否状態を引き起こしたりする可能性があります。Nessusはこれらの問題をテストしていませんが、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

MySQLバージョン5.7.15以降にアップグレードしてください。

関連情報

http://www.nessus.org/u?bac902d5

https://dev.mysql.com/doc/relnotes/mysql/5.7/en/news-5-7-15.html

http://www.nessus.org/u?fbd97f45

http://www.nessus.org/u?453a538d

プラグインの詳細

深刻度: Critical

ID: 93380

ファイル名: mysql_5_7_15_rpm.nasl

バージョン: 1.12

タイプ: local

エージェント: unix

ファミリー: Databases

公開日: 2016/9/8

更新日: 2020/6/3

依存関係: ssh_get_info.nasl

リスク情報

CVSS スコアのソース: CVE-2016-6662

VPR

リスクファクター: Critical

スコア: 9.2

CVSS v2

リスクファクター: Critical

Base Score: 10

Temporal Score: 7.8

ベクトル: AV:N/AC:L/Au:N/C:C/I:C/A:C

現状ベクトル: E:POC/RL:OF/RC:C

CVSS v3

リスクファクター: Critical

Base Score: 9.8

Temporal Score: 8.8

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

現状ベクトル: E:P/RL:O/RC:C

脆弱性情報

CPE: cpe:/a:oracle:mysql, p-cpe:/a:amazon:linux:mysql, p-cpe:/a:centos:centos:mysql, p-cpe:/a:fedoraproject:fedora:mysql, p-cpe:/a:fermilab:scientific_linux:mysql, p-cpe:/a:novell:opensuse:mysql, p-cpe:/a:novell:suse_linux:mysql, p-cpe:/a:oracle:linux:mysql, p-cpe:/a:redhat:enterprise_linux:mysql

必要な KB アイテム: Host/local_checks_enabled

エクスプロイトが利用可能: true

エクスプロイトの容易さ: Exploits are available

パッチ公開日: 2016/9/6

脆弱性公開日: 2016/9/6

参照情報

CVE: CVE-2016-3492, CVE-2016-5507, CVE-2016-5616, CVE-2016-5617, CVE-2016-5625, CVE-2016-5626, CVE-2016-5629, CVE-2016-5632, CVE-2016-6662, CVE-2016-6663, CVE-2016-8283, CVE-2016-8286

BID: 92911, 92912, 93612, 93614, 93617, 93638, 93650, 93668, 93678, 93693, 93737, 93745

EDB-ID: 40360