SUSE SLED12 / SLES12 セキュリティ更新:tiff(SUSE-SU-2016:2271-1)

high Nessus プラグイン ID 93439

概要

リモート SuSE ホストに1つ以上のセキュリティ更新がありません。

説明

tiff 用のこの更新は、次の問題を修正します:

- CVE-2015-8781、CVE-2015-8782、CVE-2015-8783:
無効なイメージへの領域外書き込み(bsc#964225)

- CVE-2016-3186:gif2tiff のバッファオーバーフロー(bnc#973340)。

- CVE-2016-5875:PixarLog 圧縮フォーマットを使用する際のヒープベースのバッファオーバーフロー(bsc#987351)

- CVE-2016-5316:tif_pixarlog.c における PixarLogCleanup() 関数の領域外読み取り(bsc#984837)

- CVE-2016-5314:PixarLogDecode() 関数の領域外書き込み(bsc#984831)

- CVE-2016-5317:libtiff.so における PixarLogDecode() 関数の領域外書き込み(bsc#984842)

- CVE-2016-5320:tif_pixarlog.c における PixarLogDecode() 関数の領域外書き込み(bsc#984808)

注意:Tenable Network Security は、前述の記述ブロックを SUSE セキュリティアドバイザリから直接抽出しています。Tenable では、できる限り新たな問題を持ち込まないように、自動的に整理して書式設定するようにしています。

ソリューション

この SUSE セキュリティ更新をインストールするには、YaST online_update を使用してください。
または、お使いの製品用に一覧になったコマンドを実行することも可能です。

SUSE Linux Enterprise ソフトウェア開発キット 12-SP1:zypper in -t patch SUSE-SLE-SDK-12-SP1-2016-1330=1

SUSE Linux Enterprise Server 12-SP1:zypper in -t patch SUSE-SLE-SERVER-12-SP1-2016-1330=1

SUSE Linux Enterprise Desktop 12-SP1:zypper in -t patch SUSE-SLE-DESKTOP-12-SP1-2016-1330=1

お使いのシステムを最新の状態にするには、「zypper パッチ」を使用してください。

参考資料

https://bugzilla.suse.com/show_bug.cgi?id=964225

https://bugzilla.suse.com/show_bug.cgi?id=973340

https://bugzilla.suse.com/show_bug.cgi?id=984808

https://bugzilla.suse.com/show_bug.cgi?id=984831

https://bugzilla.suse.com/show_bug.cgi?id=984837

https://bugzilla.suse.com/show_bug.cgi?id=984842

https://bugzilla.suse.com/show_bug.cgi?id=987351

https://www.suse.com/security/cve/CVE-2015-8781/

https://www.suse.com/security/cve/CVE-2015-8782/

https://www.suse.com/security/cve/CVE-2015-8783/

https://www.suse.com/security/cve/CVE-2016-3186/

https://www.suse.com/security/cve/CVE-2016-5314/

https://www.suse.com/security/cve/CVE-2016-5316/

https://www.suse.com/security/cve/CVE-2016-5317/

https://www.suse.com/security/cve/CVE-2016-5320/

https://www.suse.com/security/cve/CVE-2016-5875/

http://www.nessus.org/u?196bb487

プラグインの詳細

深刻度: High

ID: 93439

ファイル名: suse_SU-2016-2271-1.nasl

バージョン: 2.12

タイプ: local

エージェント: unix

公開日: 2016/9/12

更新日: 2021/1/6

サポートされているセンサー: Frictionless Assessment AWS, Frictionless Assessment Azure, Frictionless Assessment Agent, Nessus Agent, Agentless Assessment, Nessus

リスク情報

VPR

リスクファクター: Medium

スコア: 6.7

CVSS v2

リスクファクター: Medium

Base Score: 6.8

Temporal Score: 5

ベクトル: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

CVSS v3

リスクファクター: High

Base Score: 8.8

Temporal Score: 7.7

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

現状ベクトル: CVSS:3.0/E:U/RL:O/RC:C

脆弱性情報

CPE: p-cpe:/a:novell:suse_linux:libtiff5, p-cpe:/a:novell:suse_linux:libtiff5-debuginfo, p-cpe:/a:novell:suse_linux:tiff, p-cpe:/a:novell:suse_linux:tiff-debuginfo, p-cpe:/a:novell:suse_linux:tiff-debugsource, cpe:/o:novell:suse_linux:12

必要な KB アイテム: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2016/9/9

脆弱性公開日: 2016/2/1

参照情報

CVE: CVE-2015-8781, CVE-2015-8782, CVE-2015-8783, CVE-2016-3186, CVE-2016-5314, CVE-2016-5316, CVE-2016-5317, CVE-2016-5320, CVE-2016-5875