SUSE SLES11 セキュリティ更新:mysql(SUSE-SU-2016:2343-1)

critical Nessus プラグイン ID 93615
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモート SuSE ホストに1つ以上のセキュリティ更新がありません。

説明

5.5.52 へのこの mysql の更新により、以下の問題が修正されます:
修正されたセキュリティの課題:

- CVE-2016-3477:parser サブコンポーネントの中の詳細不明な脆弱性を修正(bsc#989913)。

- CVE-2016-3521:types サブコンポーネントの中の詳細不明な脆弱性を修正(bsc#989919)。

- CVE-2016-3615:dml サブコンポーネントの中の詳細不明な脆弱性を修正(bsc#989922)。

- CVE-2016-5440:rbr サブコンポーネントの中の詳細不明な脆弱性を修正(bsc#989926)。

- CVE-2016-6662:SQL およびファイルシステムへのアクセス権を持つ悪意のあるユーザーが datadir の中に my.cnf を作成でき、特定の状況下で任意のコードを mysql として(root としてすら)実行できる可能性があります。(bsc#998309)詳細は以下を参照してください:
http://dev.mysql.com/doc/relnotes/mysql/5.5/en/news-5-5- 52.html http://dev.mysql.com/doc/relnotes/mysql/5.5/en/news-5-5- 51.html http://dev.mysql.com/doc/relnotes/mysql/5.5/en/news-5-5- 50.html修正されたバグ:

- bsc#967374:アップグレード中に mysql マルチインスタンスを適切に再起動

- bnc#937258:マルチスクリプトがクラッシュ後に再起動

注意:Tenable Network Security は、前述の記述ブロックを SUSE セキュリティアドバイザリから直接抽出しています。Tenable では、できる限り新たな問題を持ち込まないように、自動的に整理して書式設定するようにしています。

ソリューション

この SUSE セキュリティ更新をインストールするには、YaST online_update を使用してください。
または、お使いの製品用に一覧になったコマンドを実行することも可能です。

SUSE OpenStack Cloud 5:zypper in -t patch sleclo50sp3-mysql-12752=1

SUSE Manager Proxy 2.1:zypper in -t patch slemap21-mysql-12752=1

SUSE Manager 2.1:zypper in -t patch sleman21-mysql-12752=1

SUSE Linux Enterprise ソフトウェア開発キット 11-SP4:zypper in -t patch sdksp4-mysql-12752=1

SUSE Linux Enterprise Server 11-SP4:zypper in -t patch slessp4-mysql-12752=1

SUSE Linux Enterprise Server 11-SP3-LTSS:zypper in -t patch slessp3-mysql-12752=1

SUSE Linux Enterprise Point of Sale 11-SP3:zypper in -t patch sleposp3-mysql-12752=1

SUSE Linux Enterprise Debuginfo 11-SP4:zypper in -t patch dbgsp4-mysql-12752=1

SUSE Linux Enterprise Debuginfo 11-SP3:zypper in -t patch dbgsp3-mysql-12752=1

お使いのシステムを最新の状態にするには、「zypper パッチ」を使用してください。

関連情報

https://dev.mysql.com/doc/relnotes/mysql/5.5/en/news-5-5-50.html

https://dev.mysql.com/doc/relnotes/mysql/5.5/en/news-5-5-51.html

https://dev.mysql.com/doc/relnotes/mysql/5.5/en/news-5-5-52.html

https://bugzilla.suse.com/show_bug.cgi?id=937258

https://bugzilla.suse.com/show_bug.cgi?id=967374

https://bugzilla.suse.com/show_bug.cgi?id=989913

https://bugzilla.suse.com/show_bug.cgi?id=989919

https://bugzilla.suse.com/show_bug.cgi?id=989922

https://bugzilla.suse.com/show_bug.cgi?id=989926

https://bugzilla.suse.com/show_bug.cgi?id=998309

https://www.suse.com/security/cve/CVE-2016-3477/

https://www.suse.com/security/cve/CVE-2016-3521/

https://www.suse.com/security/cve/CVE-2016-3615/

https://www.suse.com/security/cve/CVE-2016-5440/

https://www.suse.com/security/cve/CVE-2016-6662/

http://www.nessus.org/u?26d998e2

プラグインの詳細

深刻度: Critical

ID: 93615

ファイル名: suse_SU-2016-2343-1.nasl

バージョン: 2.12

タイプ: local

エージェント: unix

公開日: 2016/9/21

更新日: 2021/1/19

依存関係: ssh_get_info.nasl

リスク情報

VPR

リスクファクター: High

スコア: 7.4

CVSS v2

リスクファクター: Critical

Base Score: 10

Temporal Score: 7.8

ベクトル: AV:N/AC:L/Au:N/C:C/I:C/A:C

現状ベクトル: E:POC/RL:OF/RC:C

CVSS v3

リスクファクター: Critical

Base Score: 9.8

Temporal Score: 8.8

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

現状ベクトル: E:P/RL:O/RC:C

脆弱性情報

CPE: p-cpe:/a:novell:suse_linux:libmysql55client18, p-cpe:/a:novell:suse_linux:libmysql55client_r18, p-cpe:/a:novell:suse_linux:mysql, p-cpe:/a:novell:suse_linux:mysql-client, p-cpe:/a:novell:suse_linux:mysql-tools, cpe:/o:novell:suse_linux:11

必要な KB アイテム: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

エクスプロイトが利用可能: true

エクスプロイトの容易さ: Exploits are available

パッチ公開日: 2016/9/20

脆弱性公開日: 2016/7/21

参照情報

CVE: CVE-2016-3477, CVE-2016-3521, CVE-2016-3615, CVE-2016-5440, CVE-2016-6662