OpenSSL 1.1.0 < 1.1.0aの複数の脆弱性

high Nessus プラグイン ID 93816
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモートサービスは、複数の脆弱性の影響を受けます。

説明

バナーによると、リモートホストで1.1.0aより前のバージョンの OpenSSL 1.1.0が実行されています。したがって、次の脆弱性の影響を受けます。- クライアントからの過大なOCSPステータスリクエストの拡張機能が不適切に処理されているため、サービス拒否の脆弱性がt1_lib.cのssl_parse_clienthello_tlsext()関数にあります。認証されていないリモートの攻撃者がこれを悪用し、大きなOCSPステータスリクエスト拡張を介してメモリリソースを不足させ、サービス拒否状態を引き起こす可能性があります。(CVE-2016-6304)- 空のレコードが不適切に処理されているため、rec_layer_s3.cのSSL_peek()関数に欠陥があります。認証されていないリモートの攻撃者がこれを悪用し、SSL_peek呼び出しで長さがゼロのレコードをトリガーして無限ループを発生させ、サービス拒否状態を引き起こす可能性があります。(CVE-2016-6305)- メモリを割り当てる前に過度の長さを調べないため、サービス拒否の脆弱性が状態マシン実装にあります。認証されていないリモートの攻撃者がこれを悪用し、細工されたTLSメッセージを使用してメモリリソースを枯渇させる可能性があります。(CVE-2016-6307)- 長すぎるDTLSメッセージが不適切に処理されるため、サービス拒否の脆弱性がDTLS実装にあります。認証されていないリモートの攻撃者がこれを悪用し、細工されたDTLSメッセージを使用してメモリリソースを枯渇させる可能性があります。(CVE-2016-6308)- 暗号化した接続の確立に長期キーが使用されるため、GOST暗号スイートに欠陥があります。中間にいる攻撃者がこれを悪用し、Key Compromise Impersonation(KCI)攻撃によりサーバーになりすます可能性があります。

ソリューション

OpenSSLバージョン1.1.0a以降にアップグレードしてください。GOST暗号スイートの脆弱性は、公式リリースではまだベンダーによって修正されていません。ただし、この問題に対するパッチがOpenSSL githubリポジトリに提供されています。

関連情報

https://www.openssl.org/news/secadv/20160922.txt

http://www.nessus.org/u?09b29b30

プラグインの詳細

深刻度: High

ID: 93816

ファイル名: openssl_1_1_0a.nasl

バージョン: 1.8

タイプ: remote

ファミリー: Web Servers

公開日: 2016/9/30

更新日: 2019/11/14

依存関係: openssl_version.nasl

リスク情報

VPR

リスクファクター: Medium

スコア: 4.4

CVSS v2

リスクファクター: High

Base Score: 7.8

Temporal Score: 6.1

ベクトル: AV:N/AC:L/Au:N/C:N/I:N/A:C

現状ベクトル: E:POC/RL:OF/RC:C

CVSS v3

リスクファクター: High

Base Score: 7.5

Temporal Score: 6.7

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

現状ベクトル: E:P/RL:O/RC:C

脆弱性情報

CPE: cpe:/a:openssl:openssl

必要な KB アイテム: openssl/port

エクスプロイトが利用可能: true

エクスプロイトの容易さ: Exploits are available

パッチ公開日: 2016/9/22

脆弱性公開日: 2015/8/10

参照情報

CVE: CVE-2016-6304, CVE-2016-6305, CVE-2016-6307, CVE-2016-6308

BID: 93149, 93150, 93151, 93152